Greybox Browser Image ***14/05/11***

In this section you can share self-made extensions with other users of WYSIWYG Web Builder.

There are already more than 250 extensions available!
User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Greybox Browser Image ***14/05/11***

Post by BaconFries » Thu Jul 29, 2010 10:27 pm

14/05/11
***Update New Build For WB7 only****



***29/07/10***
Meets W3C Standards
Built with Extension Builder 2.0.3
ImageImage

Image

Grey Box Browser Image Extension
This is a simple way to display a external page from your site by simply clicking on a image and it will open in a lightbox style fashion you can add what ever site you wish to be displayed.

Demos at authors site
http://orangoo.com/labs/GreyBox/

Download for Web Builder7.X.X
Only available via extension manager
Last edited by BaconFries on Fri Jun 24, 2011 10:25 am, edited 8 times in total.

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Thu Jul 29, 2010 10:28 pm

Greybox Browser Image ***29/07/10***

User avatar
hmol
 
 
Posts: 17
Joined: Wed Apr 07, 2010 1:53 pm

Post by hmol » Fri Jul 30, 2010 9:29 am

Can someone place a demo if it?

Can you also link this to text instead of a picture?

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Fri Jul 30, 2010 9:39 am

Demos at original authors site there is already a text version available since Posted: Wed May 13, 2009 3:28 pm please look here
viewtopic.php?t=19416

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sat Jul 31, 2010 10:17 am

You can view demos of how the extension works at the first posting by visting the original author site just click on the provided url below
"Demos at authors site"

This part in red refers to when the first text version was released"Posted: Wed May 13, 2009 3:28" it is not refering to when there was a demo to view...all demo examples are available at the original authors site as previously mentioned .....

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Aug 01, 2010 10:49 am

There may be a way to do this by adding a extra snippet of code to the source to allow a load event so that the page opens when a user visits the page but at present no it only works when a user clicks on a image or a text link as in previous version...

NigelShaw
 
 
Posts: 42
Joined: Fri Feb 06, 2009 1:01 am
Location: Leicester

Post by NigelShaw » Sun Aug 01, 2010 11:33 am

Hi BaconFries

thank you mate :)

i had done one in a fashion but it was very shady lol



cheers


Nigel

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Aug 01, 2010 11:45 am

Nae probs "Mate" :D is was just a matter of changing a couple of things in the text version gald to have helped....

NigelShaw
 
 
Posts: 42
Joined: Fri Feb 06, 2009 1:01 am
Location: Leicester

Post by NigelShaw » Sun Aug 01, 2010 2:18 pm

Hi,

i have found that the link doesnt seem to work. the greybox opens but just goes into the "loading" state with the circular icon but the web page doesnt appear. checking the actual links, they seem to work fine without greybox but not with. Google doesnt work either.

is it something simple im not doing right?


cheers


Nigel

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Aug 01, 2010 2:37 pm

Hi Nigel please check that you you have not ticked the checkbox in Tools>Options>Micellaneous>Preview>Disable IE security warning during preview having this ticked it seems to block the content in the greybox window...

NigelShaw
 
 
Posts: 42
Joined: Fri Feb 06, 2009 1:01 am
Location: Leicester

Post by NigelShaw » Sun Aug 01, 2010 3:07 pm

Hi BaconFries

i have looked and it is not checked. it works when i use the original version that has the text to click but not with the image.......



strange behaviour lol



Nige

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Aug 01, 2010 6:24 pm

Hi Nigel I can confirm it is a bug with "Google Chrome" the extension seems to work once uploaded to a server it just wont display in "Preview"
I have also checked it in FF, Safari, Opera, IE6/7/8 and it opens as it should in "Preview" so it seems it just "Google Chrome" being a pain in the a** I will rey and cotact the autor and see what hes says....

User avatar
BaconFries
 
 
Posts: 4162
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Aug 01, 2010 6:28 pm

@ haamster here is the code you need to open in a window when user visits your page to insert this open Page Properties and place in Between <head></head> change the "Tiltle" and "url" to the same used in the extension properties...

Code: Select all

<script type="text/javascript">
AJS.AEV(window, 'load', function() {
          GB_showPage("Title", "url");
     });
</script>

NigelShaw
 
 
Posts: 42
Joined: Fri Feb 06, 2009 1:01 am
Location: Leicester

Post by NigelShaw » Mon Aug 02, 2010 11:35 pm

Hi BaconFries

Would it be possible to add the greybox display options into the extension or post the source so I could do it? I've been playing with extensions again and got my head back into gear after a long time away lol.

I prefer the "gb_page_fs" as it takes away the ugly top banner.

Regs

Nigel

NigelShaw
 
 
Posts: 42
Joined: Fri Feb 06, 2009 1:01 am
Location: Leicester

Post by NigelShaw » Tue Aug 03, 2010 12:18 am

Hi

Well I've added the greybox options to one I have made but need to ask some advice questions.

On your extension baconfries, you see the image in the design screen. How do you do that?

How do you get the image to stay in the place you put it in the design window? Mine keeps going to the top left of the screen.....

Other than that, it works great lol


Thanks

Nigel

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests