Strange RWD problem

Questions related to the Responsive Web Design tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/respon ... esign.html
Please read this first before posting any questions! Also check out the example project to get an idea how the RWD concept works.

Responsive Web Design FAQ:
http://wysiwygwebbuilder.com/forum/view ... 10&t=63817
User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Strange RWD problem

Post by alex4orly » Sat May 23, 2020 2:26 am

I have a sample page to demonstrate the problem : https://squadron-125.org.il/page1.html

The page is set to 1000px width
on it I have a JQuery Modal Dialog that loads automatically
Inside this dialog, I inserted an [RZ] iFrame, that loads another html page into it

If full screen mode (Windows PC, iPad in Landscape mode) it looks as expected
On Windows, if I reduce the browser width, it goes into the 768px break point, looks OK on both devices

When I further reduce the browser width in Windows, going into 480px bp - the Modal dialog remains wider, but the [RZ] iFrame is reduced in width to what is set in my 480px bp... Therefore, the dialog is no longer centered mid screen as wanted.

It looks also wrong on my Samsung Galaxy S9 / Android in Portrait and in Landscape mode

Any ideas?

Please

User avatar
Pablo
 
Posts: 20487
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange RWD problem

Post by Pablo » Sat May 23, 2020 6:42 am

To be able to help you, I need a demo project so I can see all your settings.
However, I cannot give support on [RZ]'s extension, so you will have to remove this before sharing the project.

Related FAQ:
https://www.wysiwygwebbuilder.com/forum ... 10&t=82134

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Sat May 23, 2020 7:51 am

OK, removed the RZ, just used the standard iFrame to load into it another html page
Created a one page only project : https://squadron-125.org.il/singlepage.wbs

The problems remain, you can see it in both landscape and portrait mode

Thanks in advance

User avatar
Pablo
 
Posts: 20487
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange RWD problem

Post by Pablo » Sat May 23, 2020 10:34 am

I do not see the problem in the project you have shared. For me, the window resize in all breakpoints.
However, I do not have a Samsung Galaxy, so I cannot test in on that device.

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Sat May 23, 2020 11:29 am

OK, what are you testing on? iPhone/ iPad , Windows?

Please see this document : https://squadron-125.org.il/TestPage1.pdf

Thanks again

User avatar
Pablo
 
Posts: 20487
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange RWD problem

Post by Pablo » Sat May 23, 2020 12:56 pm

Is this the same project you have shared?
I do not have that image at the bottom. This image looks like it's wider than the viewport.

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Sun May 24, 2020 5:50 am

Of course you don't - For you I created the 1 page only project but I run that page inside my pictures.

Please do the following:

1) Run the page onto your computer in full screen
2) Start reducing the width, you will get at some point to the 768 bp
3) click on the button under the image - the story about that person opens up, but please note - it opens up in a very narrow view, which is NOT what I set it for 768.
4) If you continue reducing the width, you get to the 480 bp, and click the button story - you will see that same story width as before

Why / how is that?

Ples try that on your mobile phone in portrait mode, at my end the page shows wrong

Looking forward to your feedback

Thank you

User avatar
Pablo
 
Posts: 20487
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange RWD problem

Post by Pablo » Sun May 24, 2020 7:16 am

To be able to be help, I need a demo project which demonstrates the problem.
Then I may see what is wrong based on your settings and try to point you in the right direction .

The project you have shared does not have an issue as far as I can tell.
So, can you please share a projetc that has the problem?
I cannot see what you have done based on the published page.

Note: I did see the problem in your previous example, before you remove the extension etc.

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Sun May 24, 2020 12:35 pm

Hello my teacher

Please see these 2 links:

https://squadron-125.org.il/singlepage.wbs
https://squadron-125.org.il/wrongscreen.pdf

The PDF shows two example on my mmobile phone in portrait, the same happens on my iPad
On first entry it looks wrong - the image on the left, after you scroll, it comes the correct way

Hope you can find what am I doing wrong

Thanks again

User avatar
Pablo
 
Posts: 20487
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange RWD problem

Post by Pablo » Sun May 24, 2020 1:17 pm

I have published your example here:
https://www.wysiwygwebbuilder.com/suppo ... page1.html

But I do not see the issue on my iPhone or iPhone.

However, note that the inline fame is not a child element of the dialog, it is just on top of it.

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Sun May 24, 2020 8:46 pm

Hello, Good morning from Australia

The link you provided is going to NOT FOUND:

Not Found
The requested URL was not found on this server.


I don't understand your comment that the iFrame is not a child of the Dialog, is that the problem I see?

Thank you

pajadt
 
 
Posts: 381
Joined: Sat Mar 16, 2013 11:23 am
Location: Europe
Contact:

Re: Strange RWD problem

Post by pajadt » Sun May 24, 2020 9:26 pm

Hi Alex
Based on your code all image is give 100% x 100%, only that image is not give, so that is fault, change at image Layout - Full with: true, and problem solves

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Sun May 24, 2020 10:24 pm

Sorry, what image are we talking about?

On the front welcome page, there is no image, just html text and an iFrame

Please tell me

Thanks

User avatar
Pablo
 
Posts: 20487
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange RWD problem

Post by Pablo » Mon May 25, 2020 6:22 am

The correct link is:
https://www.wysiwygwebbuilder.com/suppo ... page1.html
I don't understand your comment that the iFrame is not a child of the Dialog, is that the problem I see?
This means that the inline frame is not part of the dialog. So, the dialog and inline frame are unrelated.
You can see this in the Object Manager.

I assume you want the inline frame to be inside the dialog, so that when you close the dialog it will hide the frame?

User avatar
alex4orly
 
 
Posts: 933
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange RWD problem

Post by alex4orly » Mon May 25, 2020 6:58 am

Hi Pablo,

Well, in the meantime it seems I managed to sort it all out.
Yes, I know that the two are not related, but despite that, when I close the dialog, the iFrame goes with it...

It ssems the problem all along was with the setup of my break points.

If you can do one more thing for me with your apple devices, please visit the site
https://squadron-125.org.il/home2.php You will see that the welcome screen shows now OK (at least on Windows and Android)

Once this is dimissed
1) Click the first blue shape on the top left on landscape and portrait mode on iPad
2) Click the last image before the cat on the right

Then repeat in Portrait

And let me know if all looks OK to you.

In the process, you can learn some Hebrew...

Thanks again

Post Reply