How to get text not to show on web page

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
nrgiser
 
 
Posts: 87
Joined: Sun May 20, 2018 8:47 am

How to get text not to show on web page

Post by nrgiser » Sun Jul 14, 2019 5:59 am

Hi good people,

I have a question and I am sure there is a simple answer but I cannot figure it out currently.

I have built a new web page and on that web page I have some icons and when you drag your mouse over it, or when you touch it using a touch screen the text above appears but then disappears when the mouse has moved away from it, or it has stopped being touched.

I have set this all up and it works fine, but when the page initially loads up the text is already showing, until you either put your mouse over it or touch it then once you move away with your mouse or stop touching the icon the text then disappears. Then when you put your mouse over it again or touch it the text shows again as it should do.

I have 4 breakpoints for this web page and it happens on each one.

I have tried a few things already, like hiding the text and enabling "Include Visibility (RWD)", NOT hiding the text and enabling "Include Visibility (RWD)", Hiding the text and NOT Enabling "Include Visibility (RWD)", and NOT hiding the text and NOT Enabling "Include Visibility (RWD)". But nothing seems to work, and each time I check the text is still showing when I first open the page, which is not what i want, i do not want it to show, only when one of the icons are either being hoovered over by a mouse, or if using a touch screen, when touched.

Can someone please take a quick look and point me in the right direction, I would be very appreciative.

The web page address is >> www.ocean-bay-beach-resort.com/page1

Thank you in advance for your help in this matter.

User avatar
Pablo
 
Posts: 18682
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: How to get text not to show on web page

Post by Pablo » Sun Jul 14, 2019 7:11 am

To initial hide text, uncheck the 'visible' option in the Object Manager.
When using breakpoints the option "Include Visibility (RWD)" must be unchecked.

Note tat I cannot see your settings based on the HTML code. It need the project file for that.

nrgiser
 
 
Posts: 87
Joined: Sun May 20, 2018 8:47 am

Re: How to get text not to show on web page

Post by nrgiser » Mon Jul 15, 2019 1:18 am

Hi Pablo,

Thank you very much for your suggestion, but I had already tried that setting and did try it again after your suggestion just to make sure but it is not working correctly.

So I unchecked the "Text" in "Object Manager" so that it is hidden when the page first uploads and I also unchecked "Include Visibility (RWD)" because I am using breakpoints. I made sure this was the case on the same text box in each breakpoint too, and when I uploaded the page and did a hard refresh (CTRL + F5) the text is still showing up initially when the page loads, until I move my mouse over it and then off it, which then makes it disappear, and it works as intended.

You mention that you need the project file to see it properly, how if I cant figure this out, do I get that to you and your team.

Any further suggestions please do let me know.

I have had this working on my other pages in my project, but I was using 4 different text boxes one for each breakpoint for the same piece of text. Now I am using one text box across all 4 breakpoints so as to make the page lighter and not so much info to load up.

Thank you.

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: How to get text not to show on web page

Post by BaconFries » Mon Jul 15, 2019 1:54 am

You mention that you need the project file to see it properly, how if I cant figure this out, do I get that to you and your team.
Simply upload the file (project) to your own host/server and provide a link or upload to one of the many free file hosts such as Mediafire and again provide a url.
See the following before sending/sharing
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

nrgiser
 
 
Posts: 87
Joined: Sun May 20, 2018 8:47 am

Re: How to get text not to show on web page

Post by nrgiser » Mon Jul 15, 2019 5:46 am

Hi BaconFries,

I think I have done this correctly, it is the first time I have used Mediafire. Here is the URL it gave me >>

http://www.mediafire.com/file/cg6bz58mv ... m.wbs/file

That is the .wbs file and this is the folder with all the pictures for that web page, not sure if you need it or not >>

http://www.mediafire.com/folder/s0ktk8g ... ge_problem

I use version 14.3.4 of the web builder.

A side note

Great to see you back on the forum. Your a real asset here.

Thank you.

User avatar
Pablo
 
Posts: 18682
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: How to get text not to show on web page

Post by Pablo » Mon Jul 15, 2019 6:16 am

The implemention of your breakpoints is not correct.

The default view should be the largest view. It looks like you did not even update the default view for the layout, on my computer all objects on the default view seems to be randomly placed.

Please remove breakpoints 1920 and 1280 and cleanup the default view. The default view defines the initial state of the page.
This mean that you will need to hide the objects on the default view.

Also, it looks like there is a lot of duplicated content. For example, there are 15 menubars!
Note that most objects can be reused in breakpoints.

nrgiser
 
 
Posts: 87
Joined: Sun May 20, 2018 8:47 am

Re: How to get text not to show on web page

Post by nrgiser » Mon Jul 15, 2019 6:57 am

Hi Pablo,

Thank you for your reply.

I have only just learnt that the default view should be the largest default view. I cannot though delete breakpoints 1920 and 1280 as they are used.

This website has been live for over a year and I have not experienced any problems with it loading up the content on 1920 px even though the default is only 1280 px.

I use Google developer tools to check the different breakpoints and too make sure they are correctly proportioned and displayed in the correct way, which they are as it stands.

However, you have answered my question and what I was doing wrong, I was not hiding the text in the default view, I was hiding the text in the individual breakpoints and when I did hide them in the default view, they were not showing up anymore until you hoovered your mouse over the icon, so thank you for that.

And yes you are right, I do have some duplicated content, I have trimmed this all down and this is part of the reason to why I am redoing one page at a time. I have just got rid of the menu bars that you mentioned and now have only four, one now does each breakpoint. The only problem I now have is that I cannot change the size of the text in the menu bar for any particular breakpoint. For example in 320 px I had the text size as 6, in the 800 px it was 8 and so forth.

There is not an option like there is in a text box to click on "Enable Responsive Fonts" if you change the text size in one breakpoint in a menu bar then it changes for all the breakpoints. Unless I am overlooking something and I can indeed change the size of the text on a menu bar for a particular break point.

Yes i agree the default view looks a mess, but it all works perfectly well when the web page is uploaded and viewed in any breakpoint in any browser, will Chrome and IE, I do not have FireFox to check, but apart from my original problem, which was "how to get rid of the text above the icon" which you have kindly resolved for me.

I will look in to cleaning up the default view, but I am reluctant to delete break points 1280 and 1920, as they say, "if it ain't broke don't fix it."

Thank you Pablo and BaconFries.

User avatar
Pablo
 
Posts: 18682
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: How to get text not to show on web page

Post by Pablo » Mon Jul 15, 2019 7:03 am

For most objects you can use a different fonts in breakpoints.

nrgiser
 
 
Posts: 87
Joined: Sun May 20, 2018 8:47 am

Re: How to get text not to show on web page

Post by nrgiser » Mon Jul 15, 2019 7:35 am

It seems that I can now change the size of the text in a menu bar in each particular break point. I am sure when i built this site using 13 that I could not do so. Maybe I was wrong though, it would not be the first time.

Thank you again Pablo.

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: How to get text not to show on web page

Post by BaconFries » Mon Jul 15, 2019 11:24 pm

Hi BaconFries,
Great to see you back on the forum. Your a real asset here.
Thanks I appreciate your words... Best I can answer to this is in my (Scottish Accent) "Maybe aye Maybe Naw" only time will tell... Might be time to go over to the "Darkside" namely Wo***re** 👺

Post Reply