Protect page - access denied page

Issues related to the Login tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/login_basics.html
http://www.wysiwygwebbuilder.com/login_tools.html

TIP:
A lot of information about the login tools can be found in the help/manual.
Also checkout the demo template that is include with the software.
Post Reply
jemmy_kurnady
 
 
Posts: 8
Joined: Thu Oct 03, 2019 1:33 am

Protect page - access denied page

Post by jemmy_kurnady » Thu Oct 10, 2019 9:52 am

Hi Pablo,

Here's the map of our website
A - main page
B - protected page
C - login page

I've already put protect page functionality in page B with access denied page to C.
Page C destination page is page B (if successful login). However, this doesn't work (it keeps looping to page C - eventhough it is a successful login)
Am I missing something? I'm using WB15

Regards, Jemmy

User avatar
Pablo
 
Posts: 17950
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Protect page - access denied page

Post by Pablo » Thu Oct 10, 2019 10:32 am

I need more information to be able to help you.
Where can I download your (demo) project file?

Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

jemmy_kurnady
 
 
Posts: 8
Joined: Thu Oct 03, 2019 1:33 am

Re: Protect page - access denied page

Post by jemmy_kurnady » Thu Oct 10, 2019 11:56 am

Hi Pablo,

The folder link is https://drive.google.com/drive/folders/ ... sp=sharing
Thanks.

User avatar
Pablo
 
Posts: 17950
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Protect page - access denied page

Post by Pablo » Thu Oct 10, 2019 12:19 pm

Everything seems to be correct.
Note however that the option 'redirect to previous page' is enable, so instead of going to 'destination page' a successful login will go back to the previous page in cache.

If you cannot access the protected page even after login, then this usually mean that something is wrong with session on the server.
A common solution for this is to ask the webhost to clear the PHP session cache.

Post Reply