images destroyed

Issues related to previewing and publishing your web site.
Post Reply
taowen
 
 
Posts: 13
Joined: Thu Jul 21, 2016 8:15 pm
Location: france
Contact:

images destroyed

Post by taowen » Thu Mar 18, 2021 5:04 pm

Hi,
I recently discovered that many among the photo galeries of my pages on WWB16 ( I installed the last version) are destroyed, with black or grey ou green...rectangles. They still appears ok on the website, but if I have to correct something and republish a page, that will not match. I think it appeared when I installed WWB16, but this has already happened before. So what to do with that ? I would have to spend days correcting everything. My website is www.regis-pfaffenzeller.com but you will see nothing on it.

User avatar
Pablo
 
Posts: 23603
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: images destroyed

Post by Pablo » Thu Mar 18, 2021 6:15 pm

Maybe there is a naming conflict?
Can you please be more specific?

taowen
 
 
Posts: 13
Joined: Thu Jul 21, 2016 8:15 pm
Location: france
Contact:

Re: images destroyed

Post by taowen » Fri Mar 19, 2021 10:00 am

Thank you for your answer.
When I published my photo galleries, they were ok except a few images which had a problem with whitespaces or forbidden signes or accent, which I correct when I take notice. There was no problem when I published them, they still appear ok on my published website. But on my files with WWB16, when I check my photo galleries or sometimes some pictures added to text, many images (thunbails and images) are appearing with only a part of it, the rest is a rectangle colored of any color. How this happened, knowing that I did nothing on these pages. It might appear when I install new versions. If there is a name conflict, why now, and not before ?

taowen
 
 
Posts: 13
Joined: Thu Jul 21, 2016 8:15 pm
Location: france
Contact:

Re: images destroyed

Post by taowen » Fri Mar 19, 2021 10:11 am

for example, on that page: https://www.regis-pfaffenzeller.com/Cal ... raire.html
the map was appearing ok on the website, as it is now, but on my file this image was almost full grey, although I did nothing recently on that page.

User avatar
Pablo
 
Posts: 23603
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: images destroyed

Post by Pablo » Fri Mar 19, 2021 10:46 am

Maybe you will need to clear your brower cache?

taowen
 
 
Posts: 13
Joined: Thu Jul 21, 2016 8:15 pm
Location: france
Contact:

Re: images destroyed

Post by taowen » Mon Mar 22, 2021 7:16 am

I often clear my browser cache and did it again and nothing has changed. Anyway, That would not explain why many images (mostly thumbnails) are altered on my files, although I did nothing on these files, exept loading new version of WWB.
Another example :
I realized that on a photogalery on the website, set with « light box galery » « slimbox » (all my photogaleries have the same settings), when I click on the thumbnail, the full image appeared but impossible to go forward or back, prev or next did not appear. But apart from that, thumbnails and images were ok. I reoppened my file on WWB16, where some thumbnails are altered, could not see any mistakes, set again choices (light box galery and slimbox) , republished (all files on the page).
I checked again on the website, same problem, and now, the thumbnails are ok, but when I click on some of them, alteration appeared :
https://www.regis-pfaffenzeller.com/Ind ... adesh.html (I removed the second image but it still appears!)
https://www.regis-pfaffenzeller.com/Ind ... G_7147.JPG
https://www.regis-pfaffenzeller.com/Ind ... G_7138.JPG

Same problem on this page, not possible to go forward or backward (I didn't republished it) :
https://www.regis-pfaffenzeller.com/Ind ... s_Goa.html

User avatar
Pablo
 
Posts: 23603
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: images destroyed

Post by Pablo » Mon Mar 22, 2021 7:36 am

The software will not modify your images. They will be published "AS IS".
But it looks like some of the images did not upload correctly. This may be because of the file size or the invalid naming.
How did you publish the files?
Where there any errors in the publish log?

See also, this information about naming your files:
viewtopic.php?f=10&t=131

taowen
 
 
Posts: 13
Joined: Thu Jul 21, 2016 8:15 pm
Location: france
Contact:

Re: images destroyed

Post by taowen » Mon Mar 22, 2021 8:15 pm

Actually, it's not a problem of publishing. I know about names, I did some mistakes on names and correct them.
Some photo galeries were published some years ago, successfully. Files were ok and everything was ok on the website. I did nothing on these pages, no reason to do anything. And recently I discovered that these photo galeries had images altered on my files but were still ok on the website, and they are still ok as long as I don't republish them. Could it be possible that this happened when I loaded new version of WWB ?
I just would like to know how these alterations appeared ! Names of altered pictures are ok.
I publish with ftp. Some years ago, as I had some problems to publish important files, I bought extensions, but they disappeared with new versions.
I have no problems of publishing at the moment.

User avatar
BaconFries
 
 
Posts: 5394
Joined: Thu Aug 16, 2007 7:32 pm

Re: images destroyed

Post by BaconFries » Mon Mar 22, 2021 8:50 pm

Could it be possible that this happened when I loaded new version of WWB ?
I doubt that this has anything to do with the be software. It is more likely that the images have become corrupted on your PC or something has changed or corrupted them on your server. The following images extension naming is invalid it should end with .jpg not .JPG also looking at them you can see that they are corrupted.

https://www.regis-pfaffenzeller.com/Ind ... G_7147.JPG
https://www.regis-pfaffenzeller.com/Ind ... G_7138.JPG

User avatar
Pablo
 
Posts: 23603
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: images destroyed

Post by Pablo » Mon Mar 22, 2021 8:58 pm

I do not think this has anything to to with the software otherwise other user would have the same problem.
Also, the images will be published "AS IS".

Here is something you can try:
- publish the files locally
- upload the files with a third party ftp tool, like FileZilla.

If that does not work either then the problem is on the server side.
If it does work, then you will have to verify your FTP settings in WWB.

taowen
 
 
Posts: 13
Joined: Thu Jul 21, 2016 8:15 pm
Location: france
Contact:

Re: images destroyed

Post by taowen » Tue Mar 23, 2021 8:35 am

For publishing, I used the same settings for some years. And once again this problem of altered images appears on my files and not on my website if I don't republish the pages where the problem occured.
As for .JPG or .jpg, there are files with all pictures having .jpg, and no problems of wrong names, and with many pictures altered.
It seems I am the only one to get this problem ( how lucky ! ). This happen only on WWB, there are altered pictures nowhere else on my computer. I probably will never know the reason.
I already began to remove this files, and set them again, checking and correcting every names in case. That will take me days, and it could happen again.
I will tell you when I finish and if it's ok.
Thank's for your help.

pajadt
 
 
Posts: 455
Joined: Sat Mar 16, 2013 11:23 am
Location: Europe
Contact:

Re: images destroyed

Post by pajadt » Tue Apr 06, 2021 2:14 pm

Hi
You not need to whole life to change that, for that need 3 click
Try to find at search google replace extension name in folder,
https://www.ubergizmo.com/how-to/batch- ... s-windows/

Post Reply