WB14 incompatibility with previous versions

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
sidem
 
 
Posts: 25
Joined: Thu Feb 11, 2016 12:15 am

WB14 incompatibility with previous versions

Post by sidem » Thu Jul 12, 2018 11:04 am

I hope that bringing this issue to the General Questions will cause new approach onto the problem.

I'm using external JavaScript with minify formatting since these options have been made available for users i.e. since WB11.

I found that Google maps are displayed properly either in preview mode or after publishing by both WB11 & WB12 but the latest version - WB14 - that shows the map instantly in the working area does not display it in preview (F5) mode or after publishing.

It looks that making the map visible during creation of a website somehow made it impossible to work properly actually when it is needed more - during preview/when published.

I do not know much about possible conflict with another script as it was suggested therefore would bring the issue to your attention from the incompatibility view on the subject.

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 incompatibility with previous versions

Post by Pablo » Thu Jul 12, 2018 1:27 pm

Google Maps is a third party script. The behavior of the script is unrelated to the version of WWB.
In most cases the error is related to a missing or invalid Developer Key.

There may also be a conflict with another script you have added to the page. Again this is unrelated to WWB.

If you need further assistance then please include the URL of the page so we can see what you have done.

sidem
 
 
Posts: 25
Joined: Thu Feb 11, 2016 12:15 am

Re: WB14 incompatibility with previous versions

Post by sidem » Thu Jul 12, 2018 9:42 pm

Please understand I'm not referring to how the Google maps script works - it doesn't matter in this case. Neither developer key is an issue here nor conflict with another script.

Here's why:
Please open WB12:
1. New Website - blank page
2. Add from Ready to use Java scripts - Google maps with default settings
3. Check 'Generate external JS file' in Options -> HTML
4. Hit F5
You will see JS object with 'Ooops sth went wrong' - this is ok!

Then, please do the same 4 steps in the newest WB14.
You will see blank page i.e. no object. - this is wrong - incompatibility I was referring to.

Google maps script did not change, but your newest version did. WB14 can not do what its predecessors still can.

I am asking you for restoring functionality of an external JS as it used to be in previous versions that worked fine.

User avatar
crispy68
 
 
Posts: 401
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Re: WB14 incompatibility with previous versions

Post by crispy68 » Fri Jul 13, 2018 1:17 am

I followed your directions but I'm not seeing the issue you are having.

This is what I see:

Add ready to use javascript:
Image

Option:
Image

Preview:
Image

Tested in FF, Chrome, Edge, Opera and IE11 with same results

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 incompatibility with previous versions

Post by Pablo » Fri Jul 13, 2018 6:32 am

The only difference is that the external script is not moved to the end of the page by default. This was a bug in WB12, which has been fixed in WB14
So, to get the same behavior as in Wb12, you have to enable 'Move JavaScript to the end of the page'

sidem
 
 
Posts: 25
Joined: Thu Feb 11, 2016 12:15 am

Re: WB14 incompatibility with previous versions

Post by sidem » Fri Jul 13, 2018 2:51 pm

Now you're talking!

BRAVO!

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests