WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
Post Reply
cadtec
 
 
Posts: 32
Joined: Sat Oct 06, 2012 3:12 pm
Location: Switzerland
Contact:

WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by cadtec » Sat Jun 09, 2018 8:22 am

Hello,

WB14 Built-in Responsive Menu does not consider the entered breakpoint.

For me, with this navigationtype (in comparison to the other navigation menus with breakpoint input field), it is not comprehensible when the hamburger menu is displayed.....

Can anyone confirm this? and what is the solution?

Best regards, André

User avatar
Pablo
 
Posts: 14505
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Pablo » Sat Jun 09, 2018 10:36 am

What is the URL of the page?
And where exactly do I need to look to see the problem?

cadtec
 
 
Posts: 32
Joined: Sat Oct 06, 2012 3:12 pm
Location: Switzerland
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by cadtec » Sat Jun 09, 2018 3:22 pm

Thanks for the feedback !

The URL is: https://www.alibre.ch

For example in Firefox:
- load the page above
- press Ctrl + Shift + M
- then resize the view...

Allways I see the hamburger at 1300px, but I can not find this value into my project...???
Maybe I missed something completely?
Last edited by cadtec on Sat Jun 09, 2018 3:39 pm, edited 1 time in total.

User avatar
Pablo
 
Posts: 14505
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Pablo » Sat Jun 09, 2018 3:39 pm

I'm sorry, I do not see the problem.
It seems to work correct based on your current settings.
Can you please describe what you did expect to see?

cadtec
 
 
Posts: 32
Joined: Sat Oct 06, 2012 3:12 pm
Location: Switzerland
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by cadtec » Sat Jun 09, 2018 3:46 pm

The Hambug menu is way too early.
I want the menu to become a hamburger much later.
Even if I only have one menu entry left in the menu and the breakpoint is at 320, the Hambuger is displayed massively too early.

User avatar
Pablo
 
Posts: 14505
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Pablo » Sat Jun 09, 2018 3:57 pm

I cannot see all your settings based on the HTML code only.

But maybe this is helpful?
https://www.wysiwygwebbuilder.com/forum ... 10&t=63817
(When do I use 'Include min-width in CSS3 media queries'?)

cadtec
 
 
Posts: 32
Joined: Sat Oct 06, 2012 3:12 pm
Location: Switzerland
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by cadtec » Sun Jun 10, 2018 6:22 pm

Thank you very much, it works now with deactivated "Include min-width in CSS3 media queries".

But I don't see the connection between these two settings. I see no logic in that.

Can you give me a clue?

User avatar
Pablo
 
Posts: 14505
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Pablo » Sun Jun 10, 2018 6:26 pm

The logic is that this option changes the way breakpoints are triggered.
When "Include min-width in CSS3 media queries" is enabled, then the breakpoint will be triggered at the end of the vierport range (the next breakpoint width)
When "Include min-width in CSS3 media queries" is disabled, then the breakpoint will be triggered at the start of the viewport range (the current breakpoint width)

cadtec
 
 
Posts: 32
Joined: Sat Oct 06, 2012 3:12 pm
Location: Switzerland
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by cadtec » Mon Jun 11, 2018 5:35 am

I see, it's all clear now & thank you for the good help!
Best regards,
André

Robben7801
 
 
Posts: 5
Joined: Wed Feb 07, 2018 8:38 am

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Robben7801 » Thu Jul 12, 2018 9:52 am

We are expericing a similar randomly accuring problem. We have chosen only to use 2 formats for the RWD design, Default (page width 1200px) for desk tops and Break768px (page width 320px) for mobile devices. There is only one breakpoint set on 768px. Introducing an hamburger panelmenu on the mobile site caused spaces right and bottom on mobile devises. Enabling "Include "min-width"in CSS3 media queries" solved initially the issue. All worked fine until the last upload and the introduction of one additional javascript (we use several). See: www.combimac.com Are we overlooking something?

User avatar
Pablo
 
Posts: 14505
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Pablo » Thu Jul 12, 2018 10:47 am

What do I need to do to see the problem?
Where exactly do I need to look?

Robben7801
 
 
Posts: 5
Joined: Wed Feb 07, 2018 8:38 am

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Robben7801 » Fri Jul 13, 2018 12:01 pm

If you look at our website www.combimac.com on a mobile device, the view window is large with spaces to the right and bottom.
It did work as a fix screen, only scrollable to the page end, but suddenly it doesn't.

See also for example: http://www.responsinator.com/?url=www.combimac.com

User avatar
BaconFries
 
 
Posts: 4187
Joined: Thu Aug 16, 2007 7:32 pm

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by BaconFries » Fri Jul 13, 2018 12:52 pm

In page properties you have selected Emulate IE-8, this should be set to 'none' as IE8 is not responsive as it does not support css3 media queries.

If you are still seeing space to the right and bottom see the following
Responsive Web Design FAQ reading from: There is a large is empty space at the bottom (or right side) of my page.

Robben7801
 
 
Posts: 5
Joined: Wed Feb 07, 2018 8:38 am

Re: WB14 Built-in "Responsive Menu" Breakpoint-Turbulences...

Post by Robben7801 » Fri Jul 13, 2018 1:36 pm

Thanks for your swift input.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests