I have problems with the roles

This section is for posting questions which are not directly related to WYSIWYG Web Builder.
Examples of off topics: web server configuration, hosting, programming related questions, third party scripts.

Note that these questions will generally not be answered by the administrators of this forum.
Post Reply
saulmeza1
 
 
Posts: 9
Joined: Tue Nov 05, 2019 1:14 pm

I have problems with the roles

Post by saulmeza1 » Tue Dec 03, 2019 8:41 pm

I have problems with the roles every time I select one in the protection of the page it sends me to the access page denied I send you images of the configuration

https://www.webhostartistas.com/Signup.png
https://www.webhostartistas.com/Protect%20Page.png
https://www.webhostartistas.com/Admin.png
https://www.webhostartistas.com/EditProfile.png

everything is connected to the database but as I tell you when I select a Role it does not let me access it sends me to the access denied page

User avatar
Pablo
 
Posts: 18579
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: I have problems with the roles

Post by Pablo » Tue Dec 03, 2019 9:16 pm

Maybe there is a problem with PHP session on the server?
Does everything else work?
What is the (PHP) code of the pages?


User avatar
Pablo
 
Posts: 18579
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: I have problems with the roles

Post by Pablo » Wed Dec 04, 2019 7:27 am

In your project you have used different roles in different objects. The admin page has 'Administrator, Member and Guest', the registro page has 'bronce'.
Please use the same rules for all objects.

Also, you are using way too many breakpoints. Layout grids are flexible, so you normally only need 2 or 3 breakpoints max.

Does everything else work (without user roles)?

saulmeza1
 
 
Posts: 9
Joined: Tue Nov 05, 2019 1:14 pm

Re: I have problems with the roles

Post by saulmeza1 » Mon Dec 09, 2019 9:00 pm

What would be the correct configuration of the database to make it work perfect?

This is the default setting, but it doesn't work ...

CREATE TABLE `prueba` (
`id` int(10) NOT NULL auto_increment,
`username` varchar(50) NOT NULL,
`fullname` varchar(75) NOT NULL,
`password` varchar(50) NOT NULL,
`email` varchar(75) NOT NULL,
`active` tinyint(1) NOT NULL,
`code` varchar(75),
`role` varchar(50),
`avatar` varchar(50),
PRIMARY KEY (`id`));

What I want to do is a course with different plans (access to different pages with protection), which can enter from the same login

User avatar
Pablo
 
Posts: 18579
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: I have problems with the roles

Post by Pablo » Mon Dec 09, 2019 9:18 pm

The database structure is correct.
What is the exact problem?
Where does it stop working?

saulmeza1
 
 
Posts: 9
Joined: Tue Nov 05, 2019 1:14 pm

Re: I have problems with the roles

Post by saulmeza1 » Wed Dec 11, 2019 12:58 am

I want to create restricted access areas for the different product plans that I will offer on my website, but I don't get that to happen, I did tests without interupption points and nothing the same is blocked when I assign a restriction to anyone either guest or Membership just doesn't work ... I don't know what to do anymore ...
I explain the idea is simple ... it is a member area .:

Plan A .: You can access only as a guest

Plan B .: You can access as a guest and Member

Plan C .: You can access guest, Member and Member2

How do I do it so that everyone accesses with the same login?

User avatar
Pablo
 
Posts: 18579
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: I have problems with the roles

Post by Pablo » Wed Dec 11, 2019 7:11 am

Does the standard login (without user roles) work, so you can be sure the database is setup correctly?

Once you have the basics working, you can configure the user roles in the 'login admin' and 'protected page' properties.
Then assign user roles to users with the online admin.

Post Reply