Login dialog on local machine

This section is for posting questions which are not directly related to WYSIWYG Web Builder.
Examples of off topics: web server configuration, hosting, programming related questions, third party scripts.

Note that these questions will generally not be answered by the administrators of this forum.
Post Reply
User avatar
alex4orly
 
 
Posts: 547
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Login dialog on local machine

Post by alex4orly » Sun Aug 26, 2018 7:01 am

Just installed and started using XAMPP on my Windows 8.1 machine
All works fine and I can test things before uploading to the live site, but...
If I try to access the Loging dialog by direct URL, it works fine on the website, but on my local XAMPP, it shows

This : http://www.beleuramyhome.org.au/login.jpg

I know we don't have XAMP support here, but maybe someone has an idea???

Cheers

WWBman
 
 
Posts: 642
Joined: Fri Jan 08, 2010 6:10 pm

Re: Login dialog on local machine

Post by WWBman » Sun Aug 26, 2018 9:10 am

What url are you using?
I've just tried it and it works on my test login project using: localhost/test1/index.php
index.php being the equivalent to your login.php

WWBman
 
 
Posts: 642
Joined: Fri Jan 08, 2010 6:10 pm

Re: Login dialog on local machine

Post by WWBman » Sun Aug 26, 2018 10:53 am

Are you using a MySQL database?
Is it set up the same as the 'live' one?
I guess the error may be a PHP notice error and the PHP error level in Xampp is more severe than your host's level.
Try temporarily turning off error reporting by using:
<?php
error_reporting(0);
?>

and see what happens.

User avatar
alex4orly
 
 
Posts: 547
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Login dialog on local machine

Post by alex4orly » Sun Aug 26, 2018 8:41 pm

Hi WWBman,

The "Problem" started here - https://www.wysiwygwebbuilder.com/forum ... ead#unread
I asked what is the purpose of the two final code lines generated by WWB :

$username = isset($_COOKIE['username']) ? $_COOKIE['username'] : '';
$password = isset($_COOKIE['password']) ? $_COOKIE['password'] : '';

I didn't get an answer and commented those two lines out, I didn't understand what are they for.
It seems that commenting those out, doesnwt cause a problem on the live server, but XAMPP shows the error.

After un-commenting the 2 line, XAMPP works just fine

Thank you

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests