14 Layout Grid borders alignment issue

Questions related to the Responsive Web Design tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/respon ... esign.html
Please read this first before posting any questions! Also check out the example project to get an idea how the RWD concept works.

Responsive Web Design FAQ:
http://wysiwygwebbuilder.com/forum/view ... 10&t=63817
Post Reply
katman
 
 
Posts: 95
Joined: Sun Dec 21, 2008 7:02 am

14 Layout Grid borders alignment issue

Post by katman » Thu May 31, 2018 12:37 am

Hi,

testing out some of 14's updates. the pic below is a layout grid with individual boarders plus over all border. There is one text element in each box and there seems to be an alignment issue. It renders fine in the preview with text but as you can see, not when elements are different sizes.

All properties are "center" "middle"

Image

Image


IN BROWSER PREVIEW

Image

Image

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: 14 Layout Grid borders alignment issue

Post by Pablo » Thu May 31, 2018 6:14 am

This is normal behavior. A layout grid column is only a tall as its contents. With standard CSS you cannot make two columns with different contents the same height, unless you make the height fixed.
It is possible with flexbox.

The incorrect border rendering will be fixed in the next update.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests