Objects outside viewport related to 320px

Questions related to the Responsive Web Design tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/respon ... esign.html
Please read this first before posting any questions! Also check out the example project to get an idea how the RWD concept works.

Responsive Web Design FAQ:
http://wysiwygwebbuilder.com/forum/view ... 10&t=63817
Post Reply
Rick47
 
 
Posts: 1
Joined: Wed Jan 31, 2018 4:50 pm

Objects outside viewport related to 320px

Post by Rick47 » Wed Jan 31, 2018 5:22 pm

I know there are a lot of threads related to this, and I have read most, if not all; so apologies if I've missed something.
I mostly get these errors when in the 320px break view and relate to hidden objects (in this break view) which are only seen in the default view. It seems quite logical to me that an object that is say 700 wide (in the default view) cannot fit into the view of 320 - but why is it an error?
After all, it is flagged as hidden and will not appear in the 320 view.
Of course I get no such errors in the default view, which is what I would expect.
Does WB try and resolve/render these objects in 320px even though they are flagged as hidden?
Can I ignore these errors relating to hidden objects in the 320 view?

User avatar
Pablo
 
Posts: 16746
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Objects outside viewport related to 320px

Post by Pablo » Wed Jan 31, 2018 6:14 pm

Does WB try and resolve/render these objects in 320px even though they are flagged as hidden?
Because even if objects are hidden they still may affect the page size, which can cause scrollbars on smaller screens.

If you have tested your layout on smaller screens and do not get a scrollbar at the bottom then you can ignore the warning (right click->Hide warning)

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests