Page 3 of 4

Re: Inconsistent results with mobile version of my site

Posted: Tue Jan 02, 2018 10:07 pm
by Pablo
You see what I'm trying to do ..is it fundamentally correct at least, 6 floating layers over a slideshow inside a layoutgrid?
This should work. However I think at some point layers and layout grid have been mixed up because they were nested/and/or on top of each other.
There is still a conflict somewhere, but for me it may also take several hours to figure out what it is.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 1:16 am
by jddg
Yes, it has been frustrating. I guess I'll have to start from scratch. Can you suggest a good common px dimension for my design? ..and breakpoints?

https://www.danger.graphics/index.htm

Thank you again for your help! Do like WWB

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 2:31 am
by jddg
Please see my previous post. I've since started the new site from scratch, no copied elements whatsoever. Already having issues. Please see below..

https://1drv.ms/u/s!AkLAWCMtcu-1ge9hBKzNbStJwv00Ag

I've tried various layer treatments and am not getting good results at all really. Please advise, thank you again.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 8:01 am
by Pablo
It does not look like you have modified the layout in the 480 breakpoint.
The layers should be full width in design mode (also in the breakpoint).
The text objects must be re-arranged to fit inside the 480 viewport.
https://www.wysiwygwebbuilder.com/rwd_basics.html

Maybe it is a good idea to start with one template? Then you have a solid basis.
http://www.wysiwygwebbuilder.com/templates0.html

I also suggest to read this:
https://www.wysiwygwebbuilder.com/forum ... 10&t=76722

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 6:29 pm
by jddg
Thank you. I've updated the breakpoint layout and assigned the layers to full width here..

https://1drv.ms/f/s!AkLAWCMtcu-1a8HBJIW9CUd5vwE

I'm trying to build a solid foundation, its five words on two layers. I should be able to get these right. The documentation dictates that floating layers are what I want for responsive, but it appears they have to be fixed/default for my concept to work.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 6:50 pm
by Pablo
What is the exact problem with your current layout?

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 7:13 pm
by jddg
Please see my original site...

https://www.danger.graphics/index.htm

I'd like the pages to load centered "on top" of each other yet still be responsive. When I assign the layers to float, appears by default they load vertically.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 7:20 pm
by jddg
You have to scroll to see them. Thanks

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 7:24 pm
by Pablo
I'm sorry, I do not understand what you are trying to do. Can you please be more specific?
Also can you please try to do one thing at a time, so I can focus on the actual problem?

Example:
create a new project with two layers. no images, animations or other content.
Does this work for you? If not, then what is the problem?
If it work then move on to the next step, for example add an image or text.
etc.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 7:35 pm
by jddg
Thank you. I'm trying to get the words to display centered in the viewport and be responsive ..not having to scroll.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 7:38 pm
by Pablo
Do you mean you want to implement a full page layout?
http://wysiwygwebbuilder.com/carousel_fullpage.html

Note that not having to scroll has nothing to do with 'responsive'.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 7:52 pm
by jddg
https://www.danger.graphics/index.htm

This is what I want to do. My original issue ..and still, was that it didn't work consistently on mobile devices.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 8:02 pm
by jddg
I was advised to redo it to more common sizes and maybe a different approach to responsiveness. That's what I've posted earlier with the two layers, trying to get them to work like my original concept.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 9:43 pm
by Pablo
I do not think that using overlapped layers is the right approach to implement a non-scrollable layout.
It will make it very difficult to maintain the layout because everything is on top each other. That is why I suggested to use the Carousel, which is a multi-layer container.

You can use non-floating layers and show/hide them via events, but basically you will be re-implementing the Carousel in that case.
Also you will have to take into account that events affect all breakpoints, see also the FAQ.

Please understand that I am doing my best to help you, but your requirements are still not clear.
Your original layout does not look good for me on the desktop either. Everything seems to overlap because have mixed different layout methods.

Re: Inconsistent results with mobile version of my site

Posted: Wed Jan 03, 2018 10:18 pm
by jddg
Really, I'm surprised it's not displaying properly on your desktop. That's the first I've heard. Huh. Loads on my desktop and others fine really, always been consistent ..so when I say "this is what I want" I'm assuming you're seeing the same thing I am. Sorry about that. If anyone else in the forum is watching any comments would certainly be appreciated.

I very much appreciate your help, you have no idea. Your probably not obligated. It is my very first site, has been hit and miss so far.

I will look into the carousel, I'm not yet familiar. Thanks!