Carousel - Full Page

Questions related to the Responsive Web Design tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/respon ... esign.html
Please read this first before posting any questions! Also check out the example project to get an idea how the RWD concept works.

Responsive Web Design FAQ:
http://wysiwygwebbuilder.com/forum/view ... 10&t=63817
Post Reply
User avatar
crispy68
 
 
Posts: 253
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Carousel - Full Page

Post by crispy68 » Sat Nov 18, 2017 5:23 pm

hey Pablo,

I've noticed a couple of issues and not sure if they are bugs or not.

#1. I'm using the carousel in full page mode. I noticed that when you add breakpoints and then position all the objects within the slides, that the objects do not stay centered in the slides nor do any objects that you changed size of work (all images are same as default). It all looks correct in the workspace but when published it does not work.

Oddly enough, after playing around a bit I found a way to get it to work. What I did was this: I went back in and changed the Carousel back to 'Full width & floating', checking the box 'responsive carousel' and hitting ok. Then, I went back in leaving the responsive carousel button checked, changed it back to 'Full Page', hit ok and now it is working. The objects in each breakpoint will stay centered and any resized objects are resized now.

#2. I inserted an inline frame into the carousel. It has the same issues as #1 above. The changes in the size of the iframe in each BP is not working in the published page unless you do what I did as a workaround above.

The other issue is that I am wanting to use the light box option for the iframe. When I choose this option and select a preview image to be clicked, the resulting published image is the same size in each BP. In the workspace, the iframe image is responsive and looks correct. It appears to me that it is not adding the CSS code to each breakpoint, only once at the beginning causing it to be the same size throughout. Not sure if this is a bug as it is more of a suggestion to add this functionality.

Thanks.

User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Carousel - Full Page

Post by Pablo » Sat Nov 18, 2017 7:28 pm

I'm sorry I am currently a few days in Disneyland with my family so I cannot verify this.
I will take a look at this when I am back.

User avatar
crispy68
 
 
Posts: 253
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Re: Carousel - Full Page

Post by crispy68 » Sun Nov 19, 2017 2:48 pm

Hey Pablo,

Disneyland is awesome, enjoy your time.

Here is the link to a demo which includes the 2 images used in the demo: http://tinyurl.com/y9mspdoe

There a 3 pages in the demo: carousel-demo, carousel-demo2 & iframe

carousel-demo page: this is a simple 2 slide full page carousel with an image and iframe. In each BP, they are moved and/or resized. When previewed, it doesn't work.

carousel-demo2 page: this is the same as the first page except using my 'fix' as explained in my original post. You will notice that the image and iframe both now stay centered and resize correctly.

iframe page: Shows using the image as a place holder with lightbox option that it is not responsive despite looking correct in the work space.

Thanks.

User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Carousel - Full Page

Post by Pablo » Mon Nov 20, 2017 7:52 am

Thanks for the demo project!
You are right, the option 'Responsive Carousel' should be enabled otherwise the content of the Carousel will not be responsive.
In the latest build (11/20/2017) the option is now also visible for 'full page' mode.
I have also updated the inline frame to support responsive preview images.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests