Problem with alignment in CMS

Issues related to the CMS tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/cms_tools.html
A lot of information about the Content Manager System can be found in the help/manual. Please read this first before posting any questions! Also check out the demo template that is include with the software.

CMS trouble shooting / FAQ:
viewtopic.php?f=10&t=43245
Post Reply
Magin
 
 
Posts: 1
Joined: Wed Jun 06, 2018 12:36 am

Problem with alignment in CMS

Post by Magin » Wed Jun 06, 2018 12:42 am

Good morning!

I have a problem with the CMS editor, it does not matter if it's with CKEditor, Trumbowyg, etc ... it happens with all of them,
is that when I write a text in Word for example or any other word processor with the title centered,
the subtitle centered and italic, justified paragraph etc .., I copy said text and paste it in the CMS editor, it sticks well
with the same format that I created it in Word, it is correctly previewed and everything, the problem is that when I save and show it
in CMS View it appears all without format and aligned to the left, without the spaces and everything made a disaster, it is not the same as when I have paste it,
I have looked at all the possible ways and I do not give with the problem, to see if someone can help me.
I hope I have expressed myself well,

I do not mind uploading an example capture.

Thank you very much in advance.

User avatar
BaconFries
 
 
Posts: 4004
Joined: Thu Aug 16, 2007 7:32 pm

Re: Problem with alignment in CMS

Post by BaconFries » Wed Jun 06, 2018 1:04 am

It is always advisable to do all the writing within Web Builder itself so to ensure the formatting is valid. When you copy/paste text from MS Word or an another Word Processor it may or will contain invalid formatting. To remove any invalid formatting simply copy/paste into Notepad then into Web Builder or hold down the SHIFT key while using 'paste', this will also remove the formatting....

Please note that the CKEditor, Trumbowyg, etc are third party and not part of Web Builder and may not support copy/pasting from Word or other processors as they already have tools to format any text inserted.

User avatar
Pablo
 
Posts: 13029
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Problem with alignment in CMS

Post by Pablo » Wed Jun 06, 2018 5:59 am

The (third party) editors all use built-in editor functionality of the browser. If you copy/paste text form another editor then it may include invalid formatting and mess up the format.
You will need to do all formatting in the editor itself.
Note that WWB has not control over how these editors work. They are provided "AS IS".

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests