WWB on a Linux Desktop PC

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
User avatar
alex4orly
 
 
Posts: 986
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: WWB on a Linux Desktop PC

Post by alex4orly » Mon Jul 27, 2020 4:04 am

Yes, I tried the HTML5 object, it is not going to full screen. The clip is 16:9, so the top and bottom parts of the browser are empty.

Do you have a page sample that you can point me to?
Where in the world are you?

I am in Australia

Cheers
Alex

User avatar
rogerl
 
 
Posts: 291
Joined: Tue May 03, 2016 8:24 am

Re: WWB on a Linux Desktop PC

Post by rogerl » Mon Jul 27, 2020 7:17 am

Hi Alex,
I'm across the ditch in good old NZ. Have a look at this:
https://www.whiteshepherdsnz.com/NewSit ... index.html
This is just the html5 video with text over top.

User avatar
alex4orly
 
 
Posts: 986
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: WWB on a Linux Desktop PC

Post by alex4orly » Mon Jul 27, 2020 7:37 am

Hello to over the ditch...
That looks good, just took it a long time to start (I supose becasue the site is hosted in Israel...)
So, can you please me the setup?

Almost time for you to go to sleep

Cheers
Alex

User avatar
rogerl
 
 
Posts: 291
Joined: Tue May 03, 2016 8:24 am

Re: WWB on a Linux Desktop PC

Post by rogerl » Mon Jul 27, 2020 8:02 am

8pm, just waking up!
Probably more to do with the loading of the video and memory / processor. Only takes short time here and I'm running a I7 NUC with 16gb memory and SSD drives (a present to myself last year). That link is to my test site here in NZ. I borrowed your video.
Simple setup. New page, drag in html5 video object, double click on it, enter path to video file, set options, don't forget to tick box down bottom for full screen.
Insert other objects to suit such as text etc, apply any styling you require then preview.

User avatar
alex4orly
 
 
Posts: 986
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: WWB on a Linux Desktop PC

Post by alex4orly » Mon Jul 27, 2020 9:06 am

rogerl wrote:
Mon Jul 27, 2020 8:02 am
8pm, just waking up!
Probably more to do with the loading of the video and memory / processor. Only takes short time here and I'm running a I7 NUC with 16gb memory and SSD drives (a present to myself last year). That link is to my test site here in NZ. I borrowed your video.
Simple setup. New page, drag in html5 video object, double click on it, enter path to video file, set options, don't forget to tick box down bottom for full screen.
Insert other objects to suit such as text etc, apply any styling you require then preview.
OK, my setup is also NUC i7 16MB, SSD... Windows 10 that I want to get rid of...

I created a new page : http://beleuramyhome.org.au/sq125.mp4 this points to one of my website here is AU
My setup is : Auto play, Loop, Mute audio, Fill entire browser window is ticked.

My end result looks - unlike yours

I must be missing something

???

User avatar
rogerl
 
 
Posts: 291
Joined: Tue May 03, 2016 8:24 am

Re: WWB on a Linux Desktop PC

Post by rogerl » Mon Jul 27, 2020 10:43 am

Have uploaded the project file to my test site so you should be able to download it and use to see what i did.

https://www.whiteshepherdsnz.com/NewSit ... deorl2.wbs

You will need to double click on html5 video object and input a new path to a video on your local system before previewing or publishing to your own server. Also you can delete the file publisher object as web builder will upload the video referenced in the html5 video object.
Re your link looks like just a link to a video rather than to a web page.

User avatar
alex4orly
 
 
Posts: 986
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: WWB on a Linux Desktop PC

Post by alex4orly » Mon Jul 27, 2020 12:41 pm

OK, this works - just don't understand why do I need to include the Publisher object?
This video clip is already on the website...

Hope you can explain this to me

Thanks for your help
Alex

pajadt
 
 
Posts: 425
Joined: Sat Mar 16, 2013 11:23 am
Location: Europe
Contact:

Re: WWB on a Linux Desktop PC

Post by pajadt » Mon Jul 27, 2020 1:35 pm

Hi Alex
When a file publisher is used and the video is not in the layout grid as a background, then it can be uploaded like this, because it is independent, it is outside any object. So it's easier then the video is added to the projected folder and the video path is added to the folder where it was projected, it's easier because you don't have to upload the video separately.

Since I didn't have some time to deal with this these days, today I watched and you can use Layer to design in front of the video to place three elements, it would be easier to know the look of the design and have an idea how to do it, Roger's idea to make the video special as the background is great


if you are interested I can share the project behind the layer in front, with the layout grid e z-index setting must add to be at front
Here is project with layout grid
https://gofile.io/d/Y2gVdW

User avatar
alex4orly
 
 
Posts: 986
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: WWB on a Linux Desktop PC

Post by alex4orly » Mon Jul 27, 2020 8:40 pm

pajadt wrote:
Mon Jul 27, 2020 1:35 pm
Hi Alex
When a file publisher is used and the video is not in the layout grid as a background, then it can be uploaded like this, because it is independent, it is outside any object. So it's easier then the video is added to the projected folder and the video path is added to the folder where it was projected, it's easier because you don't have to upload the video separately.

Since I didn't have some time to deal with this these days, today I watched and you can use Layer to design in front of the video to place three elements, it would be easier to know the look of the design and have an idea how to do it, Roger's idea to make the video special as the background is great


if you are interested I can share the project behind the layer in front, with the layout grid e z-index setting must add to be at front
Here is project with layout grid
https://gofile.io/d/Y2gVdW
Hello again,

Thanks for your help in this matter, it is now resolved. It seems that just using the WWB HTML5 Video object works just fine. My mistake was that I didn't specify the clip format as 16:9 but left it as custome. I created a new page, without any grid or layer, here is a link to it:

https://squadron-125.org.il/home.html - it is a background video only, all the objects on the page are in front.
And the setup of the object is : http://www.beleuramyhome.org.au/htmlclip.jpg without any other object on this page

Thanks again
Alex

User avatar
rogerl
 
 
Posts: 291
Joined: Tue May 03, 2016 8:24 am

Re: WWB on a Linux Desktop PC

Post by rogerl » Mon Jul 27, 2020 10:22 pm

Great to see it come together and we learn something new along the way.Thanks for your help Pajadt.
All the best
Roger

User avatar
alex4orly
 
 
Posts: 986
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: WWB on a Linux Desktop PC

Post by alex4orly » Tue Jul 28, 2020 2:06 am

rogerl wrote:
Mon Jul 27, 2020 10:22 pm
Great to see it come together and we learn something new along the way.Thanks for your help Pajadt.
All the best
Roger
Hi Roger and Pajadt,

In fact, NOT yet at all. At the time of my previous post, indeed the video was playing fine in full screen and looping...
BUT - once I started placing the elemnts of the page, the video clip was playing on top of them...
So, I thought, I will place the video in it's own LAYER... That was NOT enough - I had to place all the page objects into their own layer.
BUT - now, even though I have set some breakpoints to make it responsive (all the objects are inside Layout grids) - it is no longer responsive.
I painted the layer just for now in RED, so that you can see what I mean : https://squadron-125.org.il/BGvideo.html
And the actual website for comparison : https://squadron-125.org.il/home.html (using the RZ video background player)

so, I am NOT done yet...

Any suggestions?

Thanks to you both
Alex

pajadt
 
 
Posts: 425
Joined: Sat Mar 16, 2013 11:23 am
Location: Europe
Contact:

Re: WWB on a Linux Desktop PC

Post by pajadt » Tue Jul 28, 2020 2:59 pm

Hi Alex that is problem with z-index video

add short code
insert HTML

Code: Select all

<style>
#wb_MediaPlayer1
{
   z-index: -1 !important;
}
</style>
between head tags
and problem be solved

Post Reply