No index.html

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
SergeFog
 
 
Posts: 44
Joined: Wed Apr 15, 2020 11:59 am

No index.html

Post by SergeFog » Thu Apr 16, 2020 8:22 am

I posted my site and I see it in the "FTP Directory" but I can't get into it.
And I don't see the "index.html" in the "FTP Directory".
What should I do?

User avatar
BaconFries
 
 
Posts: 4934
Joined: Thu Aug 16, 2007 7:32 pm

Re: No index.html

Post by BaconFries » Thu Apr 16, 2020 8:46 am

First ensure you have uploaded all files and check again. Second perhaps you have named the index to something else such as home?

User avatar
jerryco
 
 
Posts: 282
Joined: Fri Mar 27, 2009 2:42 pm
Location: Purmerend, Holland

Re: No index.html

Post by jerryco » Thu Apr 16, 2020 9:31 am

What is the name of the directory you published in? Often it can be public_html and that is then the first page of your website.
// Love is the acceptance of nothing / So, you're here. Now dance.

/ You want RWD? Rotate your damn phone! //

SergeFog
 
 
Posts: 44
Joined: Wed Apr 15, 2020 11:59 am

Re: No index.html

Post by SergeFog » Thu Apr 16, 2020 3:01 pm

on the hosting server the name of the directory is: PUBLIC_HTML\wysiwyg_334alef.co.il\
an there is no INDEX.HTML file
after publishing Iget
"The requested URL was not found on this server."
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

on my PC in LOCAL PUBLISH there is no INDEX.HTML file
But after publishing I can go in the site from my local disk.
?????

User avatar
Pablo
 
Posts: 21532
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: No index.html

Post by Pablo » Thu Apr 16, 2020 3:08 pm

Did you create an index page in the Site Manager?

User avatar
jerryco
 
 
Posts: 282
Joined: Fri Mar 27, 2009 2:42 pm
Location: Purmerend, Holland

Re: No index.html

Post by jerryco » Thu Apr 16, 2020 3:14 pm

PUBLIC_HTML\wysiwyg_334alef.co.il\

Do you have a website named wysiwyg_334alef.co.il ? Otherwise you will always get a not found error.

Can you try publishing to just PUBLIC_HTML? If there is nothing there?
// Love is the acceptance of nothing / So, you're here. Now dance.

/ You want RWD? Rotate your damn phone! //

SergeFog
 
 
Posts: 44
Joined: Wed Apr 15, 2020 11:59 am

Re: No index.html

Post by SergeFog » Thu Apr 16, 2020 4:19 pm

No the name isn't "wysiwyg_334alef.co.il" but "334alef.co.il"
I try in "public_html/334alef.co.il" also but not working!!!
The is NO index.html... why?

User avatar
jerryco
 
 
Posts: 282
Joined: Fri Mar 27, 2009 2:42 pm
Location: Purmerend, Holland

Re: No index.html

Post by jerryco » Thu Apr 16, 2020 4:27 pm

Did you try publishing in public_html? So you would have public_html/index.html?
// Love is the acceptance of nothing / So, you're here. Now dance.

/ You want RWD? Rotate your damn phone! //

SergeFog
 
 
Posts: 44
Joined: Wed Apr 15, 2020 11:59 am

Re: No index.html

Post by SergeFog » Thu Apr 16, 2020 4:42 pm

I can't publishing in the "public_html" there is a other domain taking the place.
I try to publish there but NO INDEX.HTML
why there is no INDEX.HTML
I'am working with a other program and it's working from public_html/334alef.co.il
The only problem is that is NO INDEX.HTML (the same in Local publish).

User avatar
Pablo
 
Posts: 21532
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: No index.html

Post by Pablo » Thu Apr 16, 2020 5:33 pm

If there is no index page then either you have removed it from the site manager or you have set to 'do not publish'.

To be able to help you, we need to see what you have done.
Please include more information, like your project file.

User avatar
BaconFries
 
 
Posts: 4934
Joined: Thu Aug 16, 2007 7:32 pm

Re: No index.html

Post by BaconFries » Thu Apr 16, 2020 5:46 pm

As Pablo's reply please provide a copy of your project so we can view it and then see what you have done. Or please take a screenshot of the site manager with all its content / pages so we can see if it contains a index page or not. As previously mentioned by myself is it possible you have renamed the index page to something else this could explain when you publish that it doesn't show....

clarkep
 
 
Posts: 105
Joined: Wed Jul 02, 2014 8:42 pm
Location: East Devon, United Kingdom
Contact:

Re: No index.html

Post by clarkep » Thu Apr 16, 2020 9:47 pm

if you do a trace on http://wysiwyg_334alef.co.il/ it says This is neither a valid IP addres nor a valid domain or url maybe this is why SergeFog can not access the site also.

Adrian
 
 
Posts: 79
Joined: Tue Jun 13, 2017 4:44 pm

Re: No index.html

Post by Adrian » Fri Apr 17, 2020 12:57 pm

Hello SergeFog,

I saw your home page ( http://334alef.co.il ), your problem is that you main page is named "Home-Page.html".

it should be "index.html".

Every Webserver, to display the content, search for a file named "index.html" or "index.php".

So, I suppose if you rename in your WWB project file your "Home_Page" in index and publish again your Website via FTP to the server, it should work.

Another way is to rename via FTP (on the Webserver) your "Home_Page.html" into "index.html".

Many Regards from Germany , Adrian

SergeFog
 
 
Posts: 44
Joined: Wed Apr 15, 2020 11:59 am

Re: No index.html

Post by SergeFog » Fri Apr 17, 2020 1:34 pm

I try to rename and also to copy the home_page.html to index html (from the CPanel) but no use.
why there is ni index.html with the publishing of my site?
you can try to go to www.334alef.co.il... you get "index of /"

User avatar
Pablo
 
Posts: 21532
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: No index.html

Post by Pablo » Fri Apr 17, 2020 1:47 pm

Your index page is wrongly named: "Index", It should be "index"

I strongly recommend to use lower case naming for your pages, because a web server is case sensitive.

Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... f=10&t=131

Post Reply