Fancybox quit working

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
User avatar
Pablo
 
Posts: 19313
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Fancybox quit working

Post by Pablo » Thu Jan 30, 2020 7:16 am

You have two versions of the CSS and JS files.

Code: Select all

<link rel="stylesheet" href="fancybox/dist/jquery.fancybox.css">
<link rel="stylesheet" href="fancybox/dist/jquery.fancybox.min.css">
<script src="fancybox/dist/jquery.fancybox.js"></script>
<script src="fancybox/dist/jquery.fancybox.min.js"></script>
Only one JS and one CSS should exist in the folder.

Code: Select all

<link rel="stylesheet" href="fancybox/dist/jquery.fancybox.min.css">
<script src="fancybox/dist/jquery.fancybox.min.js"></script>
Also, gulpfile.js and package.json should be removed.

User avatar
protectourlands
 
 
Posts: 499
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Fancybox quit working

Post by protectourlands » Thu Jan 30, 2020 3:40 pm

Thank you Pablo. Those files were in the download. I didn't add them. Regardless I removed them and it still does not work for me.
http://www.icandyexperts.com/test/fancyboxtest.html

I am beginning to think I am cursed :lol:

User avatar
Pablo
 
Posts: 19313
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Fancybox quit working

Post by Pablo » Thu Jan 30, 2020 3:58 pm

Also, remove 'bower.json'

User avatar
protectourlands
 
 
Posts: 499
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Fancybox quit working

Post by protectourlands » Thu Jan 30, 2020 4:23 pm

Thank you Pablo

Tried that also. Still nothing.

The image to pop up is in the images folder on the server. The path is correct.

Is it the .ini file? Here is how mine is written:

Code: Select all

[attribute]
rel=$ID$

[copyrights]
company=Janis Skarnelis
url=http://fancybox.net/

[init]
script=$("a[rel^='$ID$']").fancybox({$SETTINGS$});

User avatar
Pablo
 
Posts: 19313
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Fancybox quit working

Post by Pablo » Thu Jan 30, 2020 5:48 pm

The ini file is correct.
https://www.wysiwygwebbuilder.com/forum ... 10&t=80753

Note that the files should be in the root of the fancybox folder.

User avatar
protectourlands
 
 
Posts: 499
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Fancybox quit working

Post by protectourlands » Thu Jan 30, 2020 6:16 pm

Thank you Pablo

I have the files in the fancybox folder that is on the lightbox folder in system.

WYSIWYG Web Builder > system > lightbox > fancybox > files

All the files being called upon in the head code are linked correctly and opening. I'm using the latest jquery 3.4.1 Everything is there.

It's a mystery. If I could see a Web Builder published page with this lightbox working I could probably figure it out.

User avatar
Pablo
 
Posts: 19313
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Fancybox quit working

Post by Pablo » Thu Jan 30, 2020 6:29 pm


User avatar
protectourlands
 
 
Posts: 499
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Fancybox quit working

Post by protectourlands » Thu Jan 30, 2020 6:50 pm

Perfect! Thank you Pablo. I got it working. I copied your fancybox .css and .js files from the head of your page and replaced my files with those. The only thing I can think of is I had a bad file from the fancyapp download.

I am truly grateful for the time you took to help me fix this.

Post Reply