Font size not matching when preview or publish.

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
doctorroe
 
 
Posts: 4
Joined: Sun Jan 19, 2020 9:51 pm

Font size not matching when preview or publish.

Post by doctorroe » Tue Jan 21, 2020 5:24 pm

I have a simple text box inside a layout grid. Using (as a test to simplify things) ARIAL and font size 28. Looks great in DESIGNER but when I preiew / publish, the text is huge. Did an inspection of the text and it is being rendered in the preview as size 32. What is going on?

User avatar
Pablo
 
Posts: 21447
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Font size not matching when preview or publish.

Post by Pablo » Tue Jan 21, 2020 6:07 pm

Maybe you have enabled zooming in your browser?

Note that fonts will be published in pixels sizes. 28 points is 37 pixels.

User avatar
BaconFries
 
 
Posts: 4910
Joined: Thu Aug 16, 2007 7:32 pm

Re: Font size not matching when preview or publish.

Post by BaconFries » Tue Jan 21, 2020 6:34 pm

See the following table for reference on pt to px
Image

doctorroe
 
 
Posts: 4
Joined: Sun Jan 19, 2020 9:51 pm

Re: Font size not matching when preview or publish.

Post by doctorroe » Tue Jan 21, 2020 6:37 pm

Thanks for the fast reply. I want the web builder design page that shows the fonts in the correct sizee to match the published page. So I have set my text boxes for 28 points. I tthought it would render in 28 point on the screen but it renders as 37 as you said. No zoom enabled. When I do a CTRL - to somm out to 75% it looks good. SO is there no way to design in the mode that accurately represents the browser size in 100% zoom?

doctorroe
 
 
Posts: 4
Joined: Sun Jan 19, 2020 9:51 pm

Re: Font size not matching when preview or publish.

Post by doctorroe » Tue Jan 21, 2020 6:40 pm

Let me rephrase .... I am in the Builder main page and typing a text string in a size that I want on the screen. SO I am hearing that I need to see a smaller size in the builder page to insure that it is the correct size when published?

User avatar
Pablo
 
Posts: 21447
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Font size not matching when preview or publish.

Post by Pablo » Tue Jan 21, 2020 6:48 pm

The font size in the workspace should be exactly the same in the browser.

Common reasons for the browser rendering different font sizes are:
- zoom is enabled in the browser
- zoom is enabled in the WWB
- your computer is scaling text based on the DPI.
See this related FAQ: https://www.wysiwygwebbuilder.com/forum ... 10&t=85917

doctorroe
 
 
Posts: 4
Joined: Sun Jan 19, 2020 9:51 pm

Re: Font size not matching when preview or publish.

Post by doctorroe » Tue Jan 21, 2020 7:15 pm

PERFECT!!!!!!!!!! Woo Hoo !!! this fixed my issue !!

It was the DPI setting in the Builder not being turned on!

TTHank you very much !!!

Post Reply