Mobile Browser Detector in Ver 14

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
User avatar
MartinPorter
 
 
Posts: 67
Joined: Thu Jul 20, 2017 1:39 pm
Contact:

Mobile Browser Detector in Ver 14

Post by MartinPorter » Wed Aug 15, 2018 1:56 pm

Hi Everyone..

And before anyone says it - I'm upgrading all my sites using "Breakpoints" but it's taking its time.
So back to it.. I have a site with about 20-30 standard pages and therefore have the same amount of pages
in a mobile size. In the last version 12, I used the Mobile Browser Detector addon which worked very well
(not has good as using Breakpoints) but it worked. I came to modify one of the pages using version 14 saved
the project and was told that once I save-it, you can't go back to old version. not a problem with that. So uploadled
the site, tested the mod I did and everything was fine. I never thought of about having a look at the mobile site
until I was told that on every device its loading the main screen and not the mobile side.

the script is on every page, and reads " var mobile = (/iphone|ipad|ipod|android|blackberry|mini|windows\sce|palm/i.test(navigator.userAgent.toLowerCase()));
if (mobile) {
document.location = "./MyMobileMenu.html";
}

So anyone know if this addon still works on Ver14? or is something being added to ignore script?
thanks for help..

Regards
Martin....

User avatar
Pablo
 
Posts: 14029
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Mobile Browser Detector in Ver 14

Post by Pablo » Wed Aug 15, 2018 4:09 pm

I doubt that this has anything to do with WB14.
But maybe you have enabled one of the HTML/JavaScript formatting options in Tools->Option->HTML?
Or maybe you have added other conflicting script to the page?

User avatar
MartinPorter
 
 
Posts: 67
Joined: Thu Jul 20, 2017 1:39 pm
Contact:

Re: Mobile Browser Detector in Ver 14

Post by MartinPorter » Wed Aug 15, 2018 9:48 pm

spot-on again Pablo - I reset the HTML/JavaScript options saved the site then upload it again and Bingo.. worked first time :D

thanks for your help! Pablo

Regards
Martin...

Post Reply

Who is online

Users browsing this forum: Starb7 and 23 guests