Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Tue Jun 19, 2018 9:07 pm

Pablo - last question:

Where do I find as you said:

Please remove:
<script src="https://ajax.googleapis.com/ajax/libs/j ... "></script>

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by Pablo » Wed Jun 20, 2018 5:49 am

It is part of 'Html3'

See your own reply:
Here is the script I removed in Object Html3 on both sites:

<link href="stocookie/stoCookie.css" rel="stylesheet">
<script src="https://ajax.googleapis.com/ajax/libs/j ... "></script>

<script src="stocookie/stoCookie.min.js"></script>

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Wed Jun 20, 2018 9:16 am

Thanks Pablo!

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Sat Aug 18, 2018 8:35 pm

Hi Pablo!

Are you still with this thread?

Best from
Peter

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by Pablo » Sun Aug 19, 2018 7:10 am

Did you remove the code?

Note that I cannot assist with custom code.

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 5:34 pm

Hi Pablo!

Trying to post a reply but it says :

The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.

Best
Peter

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 5:42 pm

Pablo - seems like the message was too long - will try to break it up.

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 5:53 pm

Hi Pablo!

Yes I know and yes I did but still have a problem with the site(s) and its very strange.
Some sites work and some don't.

They are:
https://zelonett.no/
https://zelonettserver2.no/
https://asterudboligsameie.no/
https://lilleakerdekk.no/
https://godthaabpark.no/

This is whats been done since last time (I'll make it as short as I can).

1) In zelonett.no we have removed all the html,body tags in the HTML boxes as you mentioned:

"For example, in this website: https://asterudboligsameie.no/, it looks like you have copied another page in the HTML object (Html2).
This makes the entire page invalid and the behavior of the page will therefor be 'undefined'."

Removed the <script src="https://ajax.googleapis.com/ajax/libs/j ... "></script> from the HTML box and no cookiebar showed.
Included the <script src="https://ajax.googleapis.com/ajax/libs/j ... "></script> in the HTML box and the cookiebar showed but
slideshows, lightboxes etc stopped working (as before).

Uploaded all files many times.
Also tried other scripts with and without jquery in the script(s) but they do not work either.
Right now zelonett.no is running with no <script src="https://ajax.googleapis.com/ajax/libs/j ... "></script> in the HTML box.

The cookie script is located in
https://zelonett.no/modulerslideshow1.html
on that page only for simplicity at the time for finding out what's wrong (shall be on each page).
Done as the script says: Two lines of code in Head (One HTML box) and the rest in Use div to set position and size of the HTML (Another HTML box).
Script says: do not use the <script src="https://ajax.googleapis.com/ajax/libs/j ... "></script> if its already in your
project.

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 6:04 pm

Hi Pablo!

Still get the:
The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later

Will try again later.

Best from Peter.

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by Pablo » Mon Aug 20, 2018 6:22 pm

I'm sorry, but I really cannot help you with custom code. For me, it may also take hours (or days) to figure out how to make the script work.

I suggest that you remove all other objects from the page to see if there are any conflicts.
Your script seems to rely on jquery, so it may need an older (or newer) version.

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 7:53 pm

Hi Pablo - thanks for answer!

I have done just that and it was on its way to you but ...The server on the forum was unable to send messages... it said.
Will make it very short:
2) Bought another hosting and called it zelonettserver2.no which was clean.
Took a copy of zelonett.no site and cleaned it:
ALL the HTML boxes with:
"For example, in this website: asterudboligsameie.no, it looks like you have copied another page in the HTML object (Html2).
This makes the entire page invalid and the behavior of the page will therefor be 'undefined'."
are deleted.
All codes from other scripts in all other HTML boxes are taken out EXCEPT in zelonettserver2.no/modulerslideshow1.html where the cookie script is (to test).
Removed the jquery from the HTML box and no cookiebar showed.
Included the jquery in the HTML box and the cookiebar showed but slideshows, lightboxes etc stopped working as in Nr 1 above in zelonett.no
Also, took out ALL pages with small errors on pages which said: The page contains multiple objects with the same ID! This may cause problems in the......

Best from
Peter

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 8:09 pm

3) In asterudboligsameie.no all works with the cookie script as pr script instructions:
Two lines of code in Head (One HTML box) and the rest in Use div to set position and size of the HTML (Another HTML box) in every page - in a masterpage.
No jquery in the HTML box.
Script says: do not use the jquery if its already in your
project.


4) In lilleakerdekk.no all works with the cookie script as pr script instructions:
Two lines of code in Head (One HTML box) and the rest in Use div to set position and size of the HTML (Another HTML box) in every page - in a masterpage.
No jquery in the HTML box.


5) In godthaabpark.no all works with the cookie script as pr script instructions:
Three lines of code here in Head (One HTML box) and the rest in Use div to set position and size of the HTML (Another HTML box) in every page - in a masterpage.
Using here the jquery in the HTML box (all 3 lines of code as pr script instructions in HTML3 box).

Then I took out the code in the HTML1 box (the one all the way down - a code saying Take me to the top) in order to add the jquery GoUp! button instead. But when adding
the jquery GoUp! button - no GoUp! button showed.
Took out the jquery
in the cookie script and
then the GoUp! button showed - but no cookiebar. The site is now put back with the HTML1 box at the bottom and the
jquery is included again.

Sorry about all this but just wanted to explain whats happened.

Best from
Peter

WB is the best!

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by Pablo » Mon Aug 20, 2018 8:41 pm

If scripts do not work together then there is a conflict or error in the code.
For example, the script may generate an error at the end of the code which prevents all other scripts from working.

Usually, the browser's debugger (F12) will give you a clue what is wrong.

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Mon Aug 20, 2018 8:50 pm

Hi Pablo!

Thanks for answer - great tip - will do that and take it from there.

Thanks again Pablo - you're fantastic!

WB is the best!

peter30
 
 
Posts: 66
Joined: Tue Jan 15, 2013 6:27 pm

Re: Suddenly a lot not working-javascript, slideshows, banners, lightboxes, galleries etc

Post by peter30 » Wed Sep 05, 2018 1:19 pm

Hi Pablo.

Just some quick questions (trying to figure out the issue still).

1. The jquery-1.7.2.min.js - where does that come from - is it built into WB?

2. Just contacted the maker of the paid cookie and he said:

view-source:https://zelonett.no/modulerslideshow1.html
I see that jquery is loaded 2 times:
line 1132:
<script type="text/javascript" src="jquery-1.7.2.min.js"></script>
line 1425:
<script type="text/javascript" src="jquery-1.7.min.js"></script>
BUT, I think the main problem is the very old version of jQuery you are using, the latest is jquery 3, and if you look at the official download page,
the oldest version available is 1.12.4, so the version 1.7 isn't even supported anymore.
https://code.jquery.com/
try to load at least jQuery 1.9 or higher

Do you know why jquery is loading twice Pablo?

How do I load/use jQuery 1.9 or higher in/with WB?

Thanks Pablo you're great.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests