non-english font/characters displayed wrong in HTML

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
longman
 
 
Posts: 146
Joined: Sat May 19, 2018 1:23 pm

non-english font/characters displayed wrong in HTML

Post by longman » Sat May 19, 2018 7:20 pm

Hi guys,

I tried non-english characters in Navigation menu buttons, when I reveiew its HTML, the title and alt does not display the correct non-english characters, instead, it puts long unrelated characters/numbers

screenshot http://prntscr.com/jk0bvh

The actual word for button was in Thai - หน้าหลัก but its not in the HTML code of the button/menu.

What to do?

User avatar
Pablo
 
Posts: 13500
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: non-english font/characters displayed wrong in HTML

Post by Pablo » Sat May 19, 2018 8:25 pm

This is intentional behavior. The characters are encoded to make sure they will be displayed correct in all browsers.

longman
 
 
Posts: 146
Joined: Sat May 19, 2018 1:23 pm

Re: non-english font/characters displayed wrong in HTML

Post by longman » Sun May 20, 2018 4:40 am

Its not the same with other web design softwares I worked with. and they show it all correctly in different browsers.

Any way to correct it?

The menu buttons are meant to transfer value (the actual word as Alt or Title), not encoded unmeaningful characters.

longman
 
 
Posts: 146
Joined: Sat May 19, 2018 1:23 pm

Re: non-english font/characters displayed wrong in HTML

Post by longman » Sun May 20, 2018 5:13 am

Or maybe google can read those codes correctly?

My only concern is google bots and seo.

User avatar
BaconFries
 
 
Posts: 4120
Joined: Thu Aug 16, 2007 7:32 pm

Re: non-english font/characters displayed wrong in HTML

Post by BaconFries » Sun May 20, 2018 5:49 am

Yes, All browsers and search engines understand unicode.

longman
 
 
Posts: 146
Joined: Sat May 19, 2018 1:23 pm

Re: non-english font/characters displayed wrong in HTML

Post by longman » Sun May 20, 2018 7:15 am

Perfect, thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests