Audio Player control buttons display problem

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
nikinik7503
 
 
Posts: 3
Joined: Sat Jan 20, 2018 8:07 am

Audio Player control buttons display problem

Post by nikinik7503 » Sat Jan 20, 2018 8:18 am

Hello all and regards from Bulgaria! I love my wysiwyg but i am facing a problem with audio player.
I need in one voice over site lets say 20 audio players for voice over demos .I try to copy and paste player, not work
i try to make them separatly and give to all of them diferent names , same problem:
THE CONTROL BUTTONS WORK ON SOME PLAYERS ON SOME OF THEM ARE NOT ACTIVE.
SEE HERE: http://bulgariansound.com/#home

any help will be highly apreciated!

User avatar
Pablo
 
Posts: 14557
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Audio Player control buttons display problem

Post by Pablo » Sat Jan 20, 2018 8:29 am

The names of your files are invalid/not websafe.
There should not be spaces or other special characters in filenames.

Related FAQ:
viewtopic.php?f=10&t=131

nikinik7503
 
 
Posts: 3
Joined: Sat Jan 20, 2018 8:07 am

Re: Audio Player control buttons display problem

Post by nikinik7503 » Tue Jan 23, 2018 4:31 am

Not work. I try all what is mention and still not work.
I try to make all players only with small letters without hasj,dash ex, not work.
all players have their own number, same thing, Some work, some not.
When i preview it during preperation it works, but when i PUBLISH it , not.
ANY idea?

User avatar
BaconFries
 
 
Posts: 4190
Joined: Thu Aug 16, 2007 7:32 pm

Re: Audio Player control buttons display problem

Post by BaconFries » Tue Jan 23, 2018 4:59 am

You still have files with invalid naming. You also have file formats not supported by all browsers example of this is .wav!. I have just viewed the source code and found the following (this is just a few) of files that are invalid there may be more!
I suggest that you take the time to view each player and if it fails you then check the file and the name you have gave it. If invalid ie it has a space, starts with a number, has a mix of upper and lower case lettering then it should only be lowercase, remove the space, ensure no number at the start, write the name as one word example: "thisismysong.mp3" without the quotes.
The following are all invalid!
Note it is important that you check that the names used are valid otherwise you will still have issues. I would say that you should carefully read the following again to help you understand how to name files so you don't have continued issues.
How do I name my pages, images and other files?

nikinik7503
 
 
Posts: 3
Joined: Sat Jan 20, 2018 8:07 am

Re: Audio Player control buttons display problem

Post by nikinik7503 » Thu Feb 15, 2018 5:17 am

Still not work. I follow the remarks , yes some of the files was wrong,BUT now all media is mp3 320kbs,all names f the files are simple
for example ''martin' all payers names are also simple "player1" and still some not work.
Interesting thimng is that when i see wich one not work i replace the file and it start to work , but other one gone not active.
The players work, but just not preload the file, i have to press play and then it becaome active
Any other ideas?

User avatar
Pablo
 
Posts: 14557
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Audio Player control buttons display problem

Post by Pablo » Thu Feb 15, 2018 7:08 am

It seems to work correct now.

Note that the media player is standard HTML functionality. The browser determines how it works, not WWB.

User avatar
BaconFries
 
 
Posts: 4190
Joined: Thu Aug 16, 2007 7:32 pm

Re: Audio Player control buttons display problem

Post by BaconFries » Thu Feb 15, 2018 10:38 am

Just like Pablo has mentioned it is the browser that controls playback and not WWB. I have viewed your source and want to ask why you have used the following preload="preload"
as this is incorrect there is no preload

Code: Select all

<audio src="jenia.mp3" id="player3" controls="controls" preload="preload">
</audio>
There are only three parameters used in preload and preload is not one of them they are auto, which plays once it has loaded, metadata, which only displays the data associated with the audio file, and none, which means it will not preload.
This is documented at
https://www.w3schools.com/tags/att_audio_preload.asp
Even applying the correct parameters doesn't guarantee that it will work across all browsers as its down to the browser and whether to support or not to support. I would remove the "preload" and try either 'auto' or 'none' and see the results.

robertz
 
 
Posts: 13
Joined: Sun Jun 26, 2005 9:35 pm
Location: Florida, USA

Re: Audio Player control buttons display problem

Post by robertz » Fri Feb 16, 2018 12:38 am

You have English and Bulgarian text, right after the head tag... both cause page errors.
You should remove the text that is colored red.
It could cause display problems on different desktop and mobile devices.

<!doctype html>
<html lang="en-us">
<head>
Bulgarian voice over ,Dubbing,VO production,Video presentations, Озвучаване на рекламни клипове ,съобщения и презентации.
Male Bulgarian voice ,Female Bulgarian voice, voices

<meta charset="utf-8">
<title>BULGARIAN VOICE OVER STUDIO</title>
<meta name="description" content="Bulgarian voice over ,VO production, Озвучаване на рекламни клипове ,съобщения и презентации.
Male Bulgarian voice ,Female Bulgarian voice, voices,
ivr,commercials,promo videos,radio imaging,гласове за радио,видео,интернет,реклама,озвучаване,презентации">

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests