Apple iPAD problem

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Thu Jan 11, 2018 9:54 pm

OK, I took out the first line and have now this code in the HTML object
<object>
<embed src="http://www.beleuramyhome.org.au/videoblog.html" width="280" height="556"> </embed>
</object>

It works OK on the Windows desktop, BUT On my Android tablet, and on my Android phone - when I select an optio / button in the blog - it jumps to a new page. I do NOT understand, how can it possibly be working correctly in Windows - the file videoblog.html has in it one Layout grid and the Blog object inside it. It the Blog setup I set it to show the content inside the iFrame - but the iFrame itself is in the calling / parent page5.html

What can I say in the Blog object to make it go to the Calling page iFrame?
I mean, in the source of the page it is target="InlineFrame1" - instead it needs to be something like target=parent.InlineFrame1 or something like that...

Here is the link again : http://www.beleuramyhome.org.au/page5.html
Last edited by alex4orly on Thu Jan 11, 2018 10:00 pm, edited 1 time in total.

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Thu Jan 11, 2018 9:58 pm

I'm sorry I cannot assist you with this code, but I do not think it's correct.
If it works then that just may be just luck rather than that it suppose to work.

I think you will have to accept that scrolling inline frames on mobile devices may not work.
But this has nothing to do with WWB.

User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Thu Jan 11, 2018 10:03 pm

I understand the iFrame problem and accept it, this is NOT a WB problem at all,
I am asking about the Blog object

What can I say in the Blog object to make it go to the Calling page iFrame?

Please have a look at the source page of this : http://www.beleuramyhome.org.au/videoblog.html

I mean, in the source of the page it is target="InlineFrame1" - instead it needs to be something like target=parent.InlineFrame1 or something like that...
Can you tell me how?

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Thu Jan 11, 2018 10:06 pm

I assume you have configured this yourself?
You can change the target of the link in the 'Link' properties of the blog item.

User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Thu Jan 11, 2018 10:09 pm

Yes, I am talking about the Link of the Blog item
If I choose the option Open in another window or iFrame - How can I tell it that the iFrame itself is NOT in the same page where the Blog object is, but in the Calling page / parrent that calls the Blog page

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Thu Jan 11, 2018 10:12 pm


User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Thu Jan 11, 2018 10:17 pm

Yes, but the parent is the entire page, I want it to go into the InlineFrame1 of that page - not to take up the entire page...

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Fri Jan 12, 2018 7:13 am

In that case use _self

User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Fri Jan 12, 2018 10:41 am

No, this can't possibly work - the BLOG object is on another HTML page, the InlineFrame1 is on a "Parent" page.

So, it looks like I found a solution - this works 50% : http://www.beleuramyhome.org.au/page1.html

I replaced the iFram in the right column with a FlexBox Container and plugged the BLOG object into it
It works correctly on an Android phone / tablet as well as on an iPhone/iPad
BUT - on any of those mobile devices - clicking on the video clip - DOES NOT start playing it...
Why?

This is my original setup : http://www.beleuramyhome.org.au/videoclips.html , both sides are two columns of a Layout grid, each column has in it an iFrame... But on iPhone it spills the object outside of the site frame...

Any suggestion as to why the loaded YouTube clip no longer works on a click?

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Fri Jan 12, 2018 10:59 am

I cannot exactly see what you have done obased onthe HTML code only.
But it looks like there is a conflict in the flexbox/layout grid settings in the smallest breakpoint.

Also I am not sure if you can use flexbox inside a layout grid. This may not work in all browsers.

User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Fri Jan 12, 2018 9:23 pm

Well, after fixing the breakpoint conflict and it now works on my Samsung Galaxy S7 mobile, both in portrait and landscape as well as on my Galaxy Tab A tablet. I am yet to find an iPhone to test it on, but in the FireFox emulator it works.
I tested it with IE, Safary, Chrome, FireFox and Opera all good.

There is one problem in small devices (Phone and Tablet) between the flex box and the iFrame options
For FlexBox : http://www.beleuramyhome.org.au/page1.html
For iFrame : http://www.beleuramyhome.org.au/videoblog.html

In the iFrame the Blog is centered on screen in Portrait and in Landscape,
With the FlexBox it is NOT, it is smaller and to the Left

In both cases it is in the right hand side column of a Layout grid

Any idea how can I fix this?

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Fri Jan 12, 2018 9:45 pm

If you use flexbox then the size of the inline frame is controlled by the flex box properties of the object. Unlike layout grids where the size is controlled by the layout grid.
http://wysiwygwebbuilder.com/flexbox.html

User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Fri Jan 12, 2018 10:40 pm

Sorry, I am a bit confused with the answer. I have here 2 cases

1) The "Original" where I have the 2 columns of the grid with an IFrame in each column : http://www.beleuramyhome.org.au/videoblog.html
2) The latest change - the column on the left has an iFrame and the video clip is played within it, the Right column DOES NOT have any iFrame in it but instead a FlexBox : http://www.beleuramyhome.org.au/page1.html

The original case is when on an iPhone / iPad - the blog object "Spills" out of the page frame which was fixed by me replacing the iFrame with the FlexBox in the right column of the Layout grid, the left column stil has in it the iFrame

Thanks again

User avatar
Pablo
 
Posts: 13002
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Apple iPAD problem

Post by Pablo » Sat Jan 13, 2018 7:47 am

My reply applies to:
With the FlexBox it is NOT, it is smaller and to the Left
The reason for this is:
If you use flexbox then the size of the inline frame/blog is controlled by the flex box properties of the object. Unlike layout grids where the size is controlled by the layout grid.
http://wysiwygwebbuilder.com/flexbox.html
In other words, the blog has a fixed size. To make it flexible you should modify the flexbox properties.

Once again I would like to note that I cannot see what you have done based on the HTML code only.
I need your project file to be able to give you more useful advise. Before you share your project please remove all non-relevant content from the project, so I do not have to go through hundreds of pages/settings to figure out what you have done.

User avatar
alex4orly
 
 
Posts: 525
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Apple iPAD problem

Post by alex4orly » Sat Jan 13, 2018 8:37 am

My current Flexbox settings are : column, nowrap,center,center,center,undefined, floating, max width 300
I will make a copy of the project and email you it just with that one single page
Are my above settings wrong?

Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests