Strange problem

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
User avatar
alex4orly
 
 
Posts: 666
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Strange problem

Post by alex4orly » Sat Dec 30, 2017 8:54 am

Hello and Happy New year

I decided to implement a user / login to this website : http://www.beleuramyhome.org.au/

While I was experimenting with it, I had a login.php to do the job and on success, the visitor was redirected to the main page of the site.

When done, I decided to change the page name (login.php) to become "index.php" with the intent of getting rid of the old index.php file

Once I did that, visiting the site at : http://www.beleuramyhome.org.au/
Was showing just the code below (which are part of the login / index.php file)

<script>
$(document).ready(function()
{
$("#jQueryButton1").button();
$("#jQueryButton2").button();
});
</script>

Those are the 2 buttons on the login.php page

To overcome it, I created a new page - index.html that has in it only one line - redirecting it to the login.php file

BUT - I fail to understand why is it ...

What is even more interesting, if I type the entire URL including the file : http://www.beleuramyhome.org.au/index.php
All was working fine....

There is no .htaccess file on the site...

Any suggestions?

Cheers

User avatar
Pablo
 
Posts: 16875
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange problem

Post by Pablo » Sat Dec 30, 2017 8:55 am

I think the landing page on the server defaults to 'index.js' instead of 'index.php'
You either will need to change this in the server configuration or disable 'use external JS file'

User avatar
alex4orly
 
 
Posts: 666
Joined: Mon Jan 20, 2014 8:17 am
Location: Australia
Contact:

Re: Strange problem

Post by alex4orly » Sat Dec 30, 2017 9:00 am

If that was the case, why did the previos index.php work?
It is true, the previous index.php was just a scrip that logged entries into a CSV file, it had no UI, therefore it wouldn't have had any .js associated with it...
So, you mean I need to check my hosting environment??

What will be the unwanted side effects if I - disable 'use external JS file' ?

User avatar
Pablo
 
Posts: 16875
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Strange problem

Post by Pablo » Sat Dec 30, 2017 10:17 am

If that was the case, why did the previos index.php work?
Probably because it did not use an external JS file.
What will be the unwanted side effects if I - disable 'use external JS file' ?
There are no side effects, only the code will be embedded in the page instead of in an external file.

Please note that this has nothing to do with the application. This is a server configuration issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests