Image Links

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
philiprbuttall
 
 
Posts: 46
Joined: Mon Feb 19, 2007 9:52 am
Location: Plymouth, UK
Contact:

Image Links

Post by philiprbuttall » Wed Sep 20, 2017 9:03 pm

I must have altered something crucial, but I just can't get a seemingly simple thing to work anymore.

Here's the scenario:

On my website I have lots of images. Some of these link to an external web address, others to various pages in my site, and all behave correctly.

I want to add a new page, which I've cloned from an existing one. This consists of lots of images of CD covers I've reviewed, and when you click on you are taken to that review.

I want to use the same format, but instead of being taken to an external web addres on clicking, I simple want the small thumbnail image to open in full size. I have does this many times on the site before, and have merely used the File link for the Image. I have used the same location for both the image itself and it's full size counterpart.

I have tried to do this on the new page, but every time I preview it locally, instead of going to the large size image, it simply tells me that Firefox can't locate the image. When I look back at the image on WYSIWYG I see that, while I set it to 'File', like the other instances, somehow this has changed, and it always shows to 'External Web Address' . The original file location is still shown, but because it's not linking to that file to produce the enlarged original, it obviously 'can't find the file'.

This is so frustrating as everything else clearly works with images, but I can't see why it appears to default to 'External Web Address' when I want it to link to 'File'.

Any suggestions gratefully received! Thank you!

User avatar
Pablo
 
Posts: 18820
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Image Links

Post by Pablo » Thu Sep 21, 2017 5:58 am

It seems to work correct for me.
What are the exact steps to reproduce this behavior?

Maybe you have used an invalid filename?
viewtopic.php?f=10&t=131

philiprbuttall
 
 
Posts: 46
Joined: Mon Feb 19, 2007 9:52 am
Location: Plymouth, UK
Contact:

Re: Image Links

Post by philiprbuttall » Thu Sep 21, 2017 7:59 am

Many thanks, Pablo!

As ever you have come to my rescue.

I was using far-too-complicated file-names for these new images, plus starting with a number, and including a few no-no characters along the way!

It's a useful reminder to keep things simple, as I suspect this is often the reason behind a number of issues that crop up from time to time, and we don't always think to check the obvious first!

philiprbuttall
 
 
Posts: 46
Joined: Mon Feb 19, 2007 9:52 am
Location: Plymouth, UK
Contact:

Re: Image Links

Post by philiprbuttall » Thu Sep 21, 2017 9:13 am

Now I'm back up and running with the image issue, what I would like to achieve is the following:

Currently when I click on image it does what I've specified it to do - in this case it goes to File and brings up an enlarged view of the thumbnail.

But what I would like it to do, in this instance, is to move from the thumbnail to the enlarged image, not by a mouse click, but simply by hovering the mouse pointer over this.

I think this involves the Events (Properties), and I can partially see how to do this.

The thumbnail image is identified on the page as 'Image 4'

I add a new event to this, namely that on 'Mouse hover' it 'shows' Image 4 as the target.

The problem is that I assume Image 4 is still the thumbnail image, so, in theory it's simply showing itself, and therefore remaining a thumbnail.

But when selecting a Target to apply an event to, I get a dropdown list where all manner of images, banners etc are available, but not the facility to point to the large version. When arranging the Link, this is fine, as selecting File allows me to navigate to the original image, but I'm puzzled how to achieve this when there doesn't seem a facility to choose the target yourself, but simply select from the options on the drop-down list - unless 'Show' isn't the right action to select?

Basically what I want to happen in total is this:

A visitor sees a thumbnail of a review I have written on a website, he hovers his mouse over it where he can read the details and headings legibly. All of the reviews are on one website, while some are additionally on another one, too. I was intending putting a suitable icon under each image, linked to whichever website(s) the review above appears on. This was why I preferred to bring about the initial enlargement by hovering, rather than clicking.

Can this be easily achieved, I wonder? Thanking you, in anticipation!

User avatar
Pablo
 
Posts: 18820
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Image Links

Post by Pablo » Thu Sep 21, 2017 9:42 am

Did you consider using the rollover image or rollover layer?
Alternatively you can use events.
http://wysiwygwebbuilder.com/more_events.html

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 10 guests