Newbie with Layer setup issue

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
User avatar
protectourlands
 
 
Posts: 782
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Newbie with Layer setup issue

Post by protectourlands » Wed Feb 14, 2018 2:49 am

Epoc

Can you post a link to the WB file? You are doing something wrong. There is a horizontal scrollbar when I view this link
http://www.ausvts.com.au/test3/index.html

Epoc
 
 
Posts: 12
Joined: Mon Feb 12, 2018 2:11 am

Re: Newbie with Layer setup issue

Post by Epoc » Wed Feb 14, 2018 3:48 am

rogerl wrote:
Wed Feb 14, 2018 1:08 am
Android and IOS are designed to frustrate and then you have to cope with browser differences as well. Can't offer anything further. Did you actually try it out? Perhaps same idea but min-width: 100vw
I tried what you suggested but but it didn't work :(

Epoc
 
 
Posts: 12
Joined: Mon Feb 12, 2018 2:11 am

Re: Newbie with Layer setup issue

Post by Epoc » Wed Feb 14, 2018 3:50 am

protectourlands wrote:
Wed Feb 14, 2018 2:49 am
Epoc

Can you post a link to the WB file? You are doing something wrong. There is a horizontal scrollbar when I view this link
http://www.ausvts.com.au/test3/index.html
Here is the WB file:

http://www.ausvts.com.au/test3/test3.wbs

User avatar
protectourlands
 
 
Posts: 782
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Newbie with Layer setup issue

Post by protectourlands » Wed Feb 14, 2018 5:01 am

Here is what it should look like in WB
http://www.icandyexperts.com/Epoc_demo.wbs

Please read again what Pablo said about using layers of relative width that contain objects and are without breakpoints and how they view on small viewports, and the fix rogerl suggested by adding the custom style.

I hope this helps.

Epoc
 
 
Posts: 12
Joined: Mon Feb 12, 2018 2:11 am

Re: Newbie with Layer setup issue

Post by Epoc » Wed Feb 14, 2018 5:23 am

protectourlands wrote:
Wed Feb 14, 2018 5:01 am
Here is what it should look like in WB
http://www.icandyexperts.com/Epoc_demo.wbs

Please read again what Pablo said about using layers of relative width that contain objects and are without breakpoints and how they view on small viewports, and the fix rogerl suggested by adding the custom style.

I hope this helps.
I can't believe how something so simple can be so hard. I downloaded your wbs file and noticed you had selected centre in browser window (full floating screen only) as the alignment. This has changed the behavior somewhat in that the layer now extends past the window and it is now larger than the screen. I'm still confused how this can happen when I have the page size and layer set at 1250px and the ipad screen is 2048px wide.

User avatar
protectourlands
 
 
Posts: 782
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Newbie with Layer setup issue

Post by protectourlands » Wed Feb 14, 2018 5:45 am

Sorry, that should have been Center, not full floating screen only. But it doesn't change the demo. Put it at Center and you will not see a difference.

The layer is set to be relative size to the page, and the page is set for 1250. So if the layer is also 1250, that means the layer will display 100% relative to the display regardless of what the display size is. If the screen size is 2048 and the layer is 100% relative to the screen, then the layer will be 2048 width. If the screen size is 600, the layer will be 600.

User avatar
Pablo
 
Posts: 20583
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Newbie with Layer setup issue

Post by Pablo » Wed Feb 14, 2018 7:09 am

I think 1250 is too wide for the iPad. Or it is a non-standard size that the iPad cannot handle.
If you change the width to a standard size like 970 then it will work.

Here is the modified demo:
http://wysiwygwebbuilder.com/support/ep ... index.html

See also:
viewtopic.php?f=10&t=47727
(note: this article was before breakpoints and other responsive tools were available).

StudentDonald
 
 
Posts: 19
Joined: Sun Oct 19, 2014 11:36 am
Location: Michigan, US

Re: Newbie with Layer setup issue

Post by StudentDonald » Wed Feb 14, 2018 5:46 pm

If the screen pixel size is 1536 x 2048 then the view port size is most likely 768 x 1024.
The view port size does not always match the pixel screen size.
Regards

Epoc
 
 
Posts: 12
Joined: Mon Feb 12, 2018 2:11 am

Re: Newbie with Layer setup issue

Post by Epoc » Thu Feb 15, 2018 11:56 pm

Pablo wrote:
Wed Feb 14, 2018 7:09 am
I think 1250 is too wide for the iPad. Or it is a non-standard size that the iPad cannot handle.
If you change the width to a standard size like 970 then it will work.

Here is the modified demo:
http://wysiwygwebbuilder.com/support/ep ... index.html

See also:
viewtopic.php?f=10&t=47727
(note: this article was before breakpoints and other responsive tools were available).
WHOOOHOOO!!! This works!!! Changed the screen and layer size to 970 and it does what I want. Many thanks Pablo :D

One quicky, if I design the site at 1200 and create a breakpoint site at 970, will the iPad render the 970 site?

User avatar
protectourlands
 
 
Posts: 782
Joined: Sat May 24, 2008 2:16 am
Contact:

Re: Newbie with Layer setup issue

Post by protectourlands » Fri Feb 16, 2018 12:24 am

Yes, but it is not a breakpoint site. It is a breakpoint layout of the same objects of the page. It is still one web page.

To take it further, you can do a 320 layout and that will cover phones.

Epoc
 
 
Posts: 12
Joined: Mon Feb 12, 2018 2:11 am

Re: Newbie with Layer setup issue

Post by Epoc » Fri Feb 16, 2018 6:39 am

protectourlands wrote:
Fri Feb 16, 2018 12:24 am
Yes, but it is not a breakpoint site. It is a breakpoint layout of the same objects of the page. It is still one web page.

To take it further, you can do a 320 layout and that will cover phones.
Yeah just bad wording I guess but it does involve basically redoing the layout.

Anyways, thanks for everyone's input. I think I'm finally on the right track :)

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests