userdb.php not updating from website

Issues related to the Login tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/login_basics.html
http://www.wysiwygwebbuilder.com/login_tools.html

TIP:
A lot of information about the login tools can be found in the help/manual.
Also checkout the demo template that is include with the software.
Post Reply
BWoods
 
 
Posts: 8
Joined: Sat Mar 17, 2018 1:59 am

userdb.php not updating from website

Post by BWoods » Sat Mar 17, 2018 2:18 am

Hi,
I am using WYSIWYG Web Builder 12.4. I created the userdb.php with the admin object and added in users. Login to the protected pages works so the database is working. If I use the Admin or Change Password object from within WYSIWYG I can download, edit and upload the database. If I try to use the website admin page for my website to administrate the database I can see the users, but not add or edit. From the Change Password web form on my website I can input the old and new password and it does not error and takes me to the designated destination page without errors so I know the web form is seeing the database, but the database does not update. The database is located in the same directory as the website published location. Any ideas on how to correct this?
Thanks, Bob W

User avatar
Pablo
 
Posts: 13515
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: userdb.php not updating from website

Post by Pablo » Sat Mar 17, 2018 7:37 am

Did you make sure the database is writable on the server?
And is the path in your settings correct?

BWoods
 
 
Posts: 8
Joined: Sat Mar 17, 2018 1:59 am

Re: userdb.php not updating from website

Post by BWoods » Sat Mar 17, 2018 5:56 pm

I have populated the database file on the host server with 30 user logins using the WYSIWUG admin object properties so I know I can write to the database. I also used Filezilla to FTP to the host server to verify permissions are set to 777. I have verified the database is being accessed ok by login on as a few of the of users on the web site and accessing the protected pages. I can ago to the web admin page, login and see the list of users. From the admin page I can click on create new user and the window opens to input the data, but the data is not written to the database. Same for the change password function. Works from object properties to change the db, but does not write to the db from the web page. Could there be an issue writing from a secure website (https) to a db file?

User avatar
Pablo
 
Posts: 13515
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: userdb.php not updating from website

Post by Pablo » Sat Mar 17, 2018 7:09 pm

I have populated the database file on the host server with 30 user logins using the WYSIWUG admin object properties so I know I can write to the database.
The built-in editor uses FTP to create a new database file on the server. It does not mean that the script on the server has the appropriate permissions.
From the admin page I can click on create new user and the window opens to input the data, but the data is not written to the database.
This can only mean that script does not have write permissions to the file. I cannot think of anything else.

Maybe you can check the server logs (PHP log?) to see if something is wrong?

BWoods
 
 
Posts: 8
Joined: Sat Mar 17, 2018 1:59 am

Re: userdb.php not updating from website

Post by BWoods » Sun Mar 18, 2018 5:36 am

Hi Pablo,
I think you are right. The script probably does not have write permissions to the database file. Unfortunately, I do not have access to the IIS directory on the server. My host is 1and and I only have access to the directory where the site files are stored. There is a log file in my log directory that has the following info:

#Software: Microsoft Log Parser
#Version: 1.0
#Date: 2018-03-12 06:37:58
#Fields: date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
2018-03-11 22:32:35 W3SVC728409953 winshus131ga 50.21.191.82 GET / - 80 - 68.101.175.148 HTTP/1.1 Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64;+rv:58.0)+Gecko/20100101+Firefox/58.0 - - webtest.uchug.org 302 0 0 359 336 93

I'm not sure if it indicates the access issue. The support team at 1and1 are very responsive and helpful. I will put in a ticket with them and get back to you with what they have to say.
Thanks, B. Woods

BWoods
 
 
Posts: 8
Joined: Sat Mar 17, 2018 1:59 am

Re: userdb.php not updating from website

Post by BWoods » Mon Mar 19, 2018 3:10 pm

Hi Pablo,
I tried somthing different. Instead of using Filezilla to FTP to the directory on my host server at 1and1 I used their FTP web interface. Filezilla indicated the usersdb.php had read, write and execute permissions. The host web FTP interface indicated only read and execute permissions on usersdb.php. Using their FTP client I set the permissions to also modify and write. Now the database file is being written to properly and all is well. Live and learn I guess.
Thanks, B. Woods

User avatar
Pablo
 
Posts: 13515
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: userdb.php not updating from website

Post by Pablo » Mon Mar 19, 2018 3:51 pm

Thanks for clearing that up!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest