WYSIWYG CMS ( CMS php include ) ***UPDATED 15/10/2009***

In this section you can share self-made extensions with other users of WYSIWYG Web Builder.

There are already more than 250 extensions available!
User avatar
me.prosenjeet
 
 
Posts: 1282
Joined: Mon Dec 24, 2007 1:50 pm
Location: Lucknow
Contact:

Post by me.prosenjeet » Wed Oct 14, 2009 12:44 pm

I must say, WB is complete now with this CMS extension.
Much better than the News Writer extension and certainly deserves to be a part of WB 6 officially (replace News Writer if required)

Just one thing, I saw I was not getting the tiny_mce for editing the pages hence I had to manually upload the folder "tiny mce"...infact the full "jscripts" folder.

Noticed, the scripts/folders have to remain at root to function...possible to put them in a folder so it doesn't mix with the main files of the site?
Last edited by me.prosenjeet on Wed Oct 14, 2009 2:04 pm, edited 2 times in total.
.
Click here to check my Pro WB Extensions
Click here to check my Pro WB Templates
---------------------------------------------------------
www.Lucknowwebs.com
---------------------------------------------------------

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Wed Oct 14, 2009 2:00 pm

me.prosenjeet wrote:I must say, WB is complete now with this CMS extension.
Much better than the News Writer extension and certainly deserves to be a part of WB 6 officially (replace News Writer if required)
The news writer is much smaller in filesize and easyer to use than this CMS and can used in html pages.
I think also that he is not allowed to put these scripts as download on the official site.
Just one thing, I saw I was not getting the tiny_mce for editing the pages hence I had to manually upload the folder "tiny mce"...infact the full "jscripts" folder.
Yes,I didnt include the jscripts folder in the extension.
Otherwise with every new "news" page you have to upload al files again.
Noticed, the scripts/folders have to remain at root to function...possible to put them in a folder so it doesn't mix with the main files of the site
If you dont use the same foldernames than its no problem.
content
jscripts
uploaded
login.php (you can change this filename)


Important is that the pages what use the extension are in the same folder.

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Wed Oct 14, 2009 11:20 pm

I found a security problem for the ajax filemanager, download the cms and read the updated pdf.

Patr100
 
 
Posts: 144
Joined: Tue Dec 25, 2007 10:52 pm

Post by Patr100 » Fri Oct 16, 2009 1:56 am

I uploaded an inserted an image but when I preview the page I get a blank image holder with the red cross where it should be?

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Fri Oct 16, 2009 6:45 am

If you have used pages in folders ( page not in the same directorie as the cms) than the path to the file is not correct.( php include in the WB page )

Do you have this structure on your server?
Look also to the read and write settings (755) or (777) from your folders.

content
jscripts
uploaded
login.php
webbuilder pages.html
webbuilder pages.html
webbuilder pages.html

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Fri Oct 16, 2009 6:58 pm

Its not the webbuilder page what you can edit!

This cms works with the same as the News Writer except that the news page is included with php in your WB page.

The "news.html" page is generated and uploaded in the content folder and on that page you write your content.

-If you read "Edit this page!" in the editor than everything is correct.
-Type your text ,insert your images etc and click update.
-Close the editor and renew (F5) your WB page to see the changes.

Patr100
 
 
Posts: 144
Joined: Tue Dec 25, 2007 10:52 pm

Post by Patr100 » Sun Oct 18, 2009 11:01 pm

Eddy wrote:If you have used pages in folders ( page not in the same directorie as the cms) than the path to the file is not correct.( php include in the WB page )

Do you have this structure on your server?
Look also to the read and write settings (755) or (777) from your folders.

content
jscripts
uploaded
login.php
webbuilder pages.html
webbuilder pages.html
webbuilder pages.html
Yes I have that structure and read /write permission are corrrect.

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Mon Oct 19, 2009 1:14 am

Is the cms and the pages in the root directorie of your site?,if yes than the only problem I can think of are the file permissions.

Look also to the ajaxfilemanager folder permissions.

Juul
 
 
Posts: 5
Joined: Wed Aug 15, 2007 12:21 pm

Post by Juul » Mon Oct 19, 2009 6:23 am

Eddy,

Thanks for the tips :wink: , it works!!!!


Juul

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Sat Oct 24, 2009 3:55 pm

In the downloaded zip file is also a folder jscripts ,did you upload that folder to the same directorie as the pages what use the extension.

Do you have this structure on your server?
Look also to the read and write settings (755) or (777) from your folders.

content
jscripts
uploaded
login.php

webbuilder pages.html
webbuilder pages.html
webbuilder pages.html

Patr100
 
 
Posts: 144
Joined: Tue Dec 25, 2007 10:52 pm

Post by Patr100 » Sat Oct 24, 2009 4:52 pm

Eddy wrote:Is the cms and the pages in the root directorie of your site?,if yes than the only problem I can think of are the file permissions.

Look also to the ajaxfilemanager folder permissions.
All the permissions fro all the folders are set to 777 or 755.
When I upload an image it is placed in the uploads folder.

But it's stil not showing up on the page.

-

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Sat Oct 24, 2009 6:29 pm

Are all pages/folders in the root directorie!

1)login and open the news page in the editor
2)upload the image with the ajax file manager.
3)select the image in the filemanager to paste in the news page.(tick the box)
4)close the editor.
5)renew your webbuilder page.

Patr100
 
 
Posts: 144
Joined: Tue Dec 25, 2007 10:52 pm

Post by Patr100 » Sat Oct 24, 2009 7:06 pm

Eddy wrote:Are all pages/folders in the root directorie!

1)login and open the news page in the editor
2)upload the image with the ajax file manager.
3)select the image in the filemanager to paste in the news page.(tick the box)
4)close the editor.
5)renew your webbuilder page.
Yes I already siad they are al in the root folder.
I've already done the above.
I am going to empty everything and try again another time.

User avatar
Eddy
 
 
Posts: 489
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Sat Oct 24, 2009 7:40 pm

Sorry,there is not much to configure if all folders and pages are in the same directorie with the right folder permissions than it should work.

Maybe you need to give the ajax file manager folder read and write permissions?

Patr100
 
 
Posts: 144
Joined: Tue Dec 25, 2007 10:52 pm

Post by Patr100 » Sat Oct 24, 2009 8:27 pm

Eddy wrote:Sorry,there is not much to configure if all folders and pages are in the same directorie with the right folder permissions than it should work.

Maybe you need to give the ajax file manager folder read and write permissions?
What specific folder are you referring to?

Post Reply