Created object (editbox, etc) not fitting into correct hierarchical position

Issues related to forms.
Post Reply
MHW
 
 
Posts: 2
Joined: Tue Feb 13, 2018 11:29 pm

Created object (editbox, etc) not fitting into correct hierarchical position

Post by MHW » Tue Feb 13, 2018 11:50 pm

I've been struggling with this issue for some time now. Couldn't find a similar problem in the forum, that's why I'm posting this (my first post!).

I have a jQuerytabs with several tabs inside a form.

The issue is that I cannot properly create new objects inside the jQuerytabs that is inside the form.
The object created is created inside the form, but not inside the jQuerytabs; therefore, it is showed along all tabs of the jQuerytabs. Instead of being showed only in the tab where it belongs (and where I created it).
This behaviour is clear in the Object Manager hierarchical structure. The object is "inside" the form, but not "inside" the jQuerytabs.

I tried to cut the object, paste it outside the form and then move it into the jQuerytabs => no result.
I tried to create it outside the form and then move it into the jQuerytabs => no result.
The jQuerytabs is not locked.

My web site was originally built with a WB9 version (yes, I'm an old customer) and I had not this problem (6 tabs plenty of objects properly showed). Only when I upgraded to WB12 this issue appeared to me. I opened the original site (WB9) into WB12 and then continued to work from there.
The existing objects continue to show into the correct tabs, but the newly created ones do not fit into any of the tabs of the jQuerytabs as per described above.
However, if I pick an existing (and properly displayed object) and move it out of jQuerytabs (and the form) and after that bring it back to the jQuerytabs it will show the same (incorrect) behaviour as the new objects.

What Am I missing? Or could it be an inconsistency between WB versions? Upgraded to 12.3.1 but the problem remains.
Please advise. Thanks.

User avatar
Pablo
 
Posts: 18425
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Created object (editbox, etc) not fitting into correct hierarchical position

Post by Pablo » Wed Feb 14, 2018 6:51 am

It sounds like the z-order of the tab is lower than the form, so when you drag objects to the tab they will instead go to the form.
This may work:
- move the tab outside the form
- use the arrange tools to move the tab to the front
- move the tab back into the form.

Note that nested layers (like Carousel, Tab, Accordions) are not officially supported. They were not designed to be used this way. But single nesting should work.

Tip: always include a demo project so we can see hat you have done.

MHW
 
 
Posts: 2
Joined: Tue Feb 13, 2018 11:29 pm

Re: *** SOLVED *** Created object (editbox, etc) not fitting into correct hierarchical position

Post by MHW » Wed Feb 14, 2018 11:48 am

YES! Problem solved.
The solution provided by Pablo regarding the z-order solved this.
There is only one tab nesting, so as Pablo said ... it works.

Thank you and congratulations for this great product.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests