Publishing defaults to the wrong location

Issues related to previewing and publishing your web site.
Post Reply
alan_sh
 
 
Posts: 750
Joined: Tue Jan 01, 2019 5:50 pm

Publishing defaults to the wrong location

Post by alan_sh » Tue Jan 19, 2021 5:41 pm

I have about 10 default locations stored in WYSIWYG to match the 10 sites I work with. Each site knows which is it's own default location and all is fine. Until recently.

Ever since I upgraded to 16.1 (I think that's when it started - may have been before), when I do a new update, the default location for my sites gets screwed up and I have to reset each of them.

Is this a known issue? Where do you save this information and is it somewhere I can get at to see what it's set to?

cheers

Alan

WWBman
 
 
Posts: 916
Joined: Fri Jan 08, 2010 6:10 pm

Re: Publishing defaults to the wrong location

Post by WWBman » Tue Jan 19, 2021 6:13 pm

They are stored in C:\Users\.....\Documents\WYSIWYG Web Builder\system\publish.dat

User avatar
Pablo
 
Posts: 23023
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Publishing defaults to the wrong location

Post by Pablo » Tue Jan 19, 2021 6:17 pm

This functionality has not changed in recent updates
But the publish.dat file may be read-only or protected by your firewall/virus scanner.

alan_sh
 
 
Posts: 750
Joined: Tue Jan 01, 2019 5:50 pm

Re: Publishing defaults to the wrong location

Post by alan_sh » Tue Jan 19, 2021 7:22 pm

I'll check it out before and after the next update

cheers

Alan

alan_sh
 
 
Posts: 750
Joined: Tue Jan 01, 2019 5:50 pm

Re: Publishing defaults to the wrong location

Post by alan_sh » Tue Jan 19, 2021 7:29 pm

I had a quick look at publish.dat and I can't see what associates a profile with a particular .WBS file.

Where should I look for that?

Alan

User avatar
Pablo
 
Posts: 23023
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Publishing defaults to the wrong location

Post by Pablo » Tue Jan 19, 2021 9:19 pm

The publish locations (server, user, passwords) are stored in publish.dat
The project only stores the name of the profile.
So, make sure all profiles have a unique name.

alan_sh
 
 
Posts: 750
Joined: Tue Jan 01, 2019 5:50 pm

Re: Publishing defaults to the wrong location

Post by alan_sh » Tue Jan 19, 2021 11:43 pm

Thanks Pablo.

What if one profile is "GMN Scouts" and another is "GMNSCcouts" - will they appear to be the same?

Alan

User avatar
Pablo
 
Posts: 23023
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Publishing defaults to the wrong location

Post by Pablo » Wed Jan 20, 2021 7:18 am

No, these should be seen as two different profiles.

alan_sh
 
 
Posts: 750
Joined: Tue Jan 01, 2019 5:50 pm

Re: Publishing defaults to the wrong location

Post by alan_sh » Wed Jan 20, 2021 10:31 am

OK - it's not that then.

I'll install the latest hotfix later today and see what happens.

Alan

User avatar
Pablo
 
Posts: 23023
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Publishing defaults to the wrong location

Post by Pablo » Wed Jan 20, 2021 10:32 am

I do not think the hotfix will make any difference. Nothing has changed related to publishing.

WWBman
 
 
Posts: 916
Joined: Fri Jan 08, 2010 6:10 pm

Re: Publishing defaults to the wrong location

Post by WWBman » Wed Jan 20, 2021 11:26 am

When you created the Publish profiles did you give each one a different Description?
I'm pretty sure this is used as the profile name in publish.dat, so as Pablo said, make sure these are unique.
Correct me if I'm wrong Pablo.

alan_sh
 
 
Posts: 750
Joined: Tue Jan 01, 2019 5:50 pm

Re: Publishing defaults to the wrong location

Post by alan_sh » Wed Jan 20, 2021 12:06 pm

Well I've just done an update and all is working as it should. I'll just keep an eye on things and see if I can see why it happened.

Alan

Post Reply