Publishing photo collage doesn't publish pictures

Issues related to previewing and publishing your web site.
Post Reply
alan_sh
 
 
Posts: 487
Joined: Tue Jan 01, 2019 5:50 pm

Publishing photo collage doesn't publish pictures

Post by alan_sh » Mon Aug 26, 2019 1:16 pm

If I add a photo collage and then add some pictures, when I publish 'modified files only' to my local disk folder, the pictures do not get copied.

If I 'publish all files', then photos do get copied across correctly.

Is this a bug or am I doing something wrong?

cheers

Alan

User avatar
Pablo
 
Posts: 17976
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Publishing photo collage doesn't publish pictures

Post by Pablo » Mon Aug 26, 2019 2:43 pm

The software not keep track of all images in a photo collage.
There is only one 'modified' flag per object. otherwise it would take a very large database to keep track of all the changes.
If you add images to an object then you will need to republisc all files.

alan_sh
 
 
Posts: 487
Joined: Tue Jan 01, 2019 5:50 pm

Re: Publishing photo collage doesn't publish pictures

Post by alan_sh » Mon Aug 26, 2019 2:54 pm

Ok, thanks. I know what to do now.

Alan

WWBman
 
 
Posts: 714
Joined: Fri Jan 08, 2010 6:10 pm

Re: Publishing photo collage doesn't publish pictures

Post by WWBman » Mon Aug 26, 2019 3:04 pm

FWIW:
If publishing the photos takes a lot of time then after the initial publish you can right-click the object and click "Don't publish assets".
This will speed up subsequent full publishes but if you add or change a photo in future you'll have to untick the option and publish all again.

Post Reply