External web file not updating.

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
Rusty
 
 
Posts: 39
Joined: Sun Aug 12, 2018 7:55 am

External web file not updating.

Post by Rusty » Thu Aug 30, 2018 4:22 pm

I cant get my web site to keep updating a external web address file from the server. I have a weather station that uploads gif files to a subdirectory on the server ever 10 minutes. The files load on my site but don't keep updating I check with filezilla and they change on the server, but every time I refresh web site it the same file with no change.

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Thu Aug 30, 2018 4:52 pm

Maybe your browser caches the old version of the page?

Rusty
 
 
Posts: 39
Joined: Sun Aug 12, 2018 7:55 am

Re: External web file not updating.

Post by Rusty » Fri Aug 31, 2018 5:35 am

If I change any other items edit text of change an image upload and refresh the changes are show, but not that file 1 gif I am using Inline Frame for that particular image. The offending link is https://garliestonlodge.co.uk/weather/summary.gif and I am using a responsive page 320px 768px & 1000px as default.

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Fri Aug 31, 2018 6:21 am

Maybe the file is read-only?
If you are using FileZilla, then I do not think this has anything to do with WWB.

Rusty
 
 
Posts: 39
Joined: Sun Aug 12, 2018 7:55 am

Re: External web file not updating.

Post by Rusty » Fri Aug 31, 2018 7:55 am

Im not using filezilla for any thing to do with WWB just using it to check that the file has update every 10 minute on the server.

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Fri Aug 31, 2018 9:07 am

How is the file updated?
How is this related to WWB?
Can you please be more specific?

Rusty
 
 
Posts: 39
Joined: Sun Aug 12, 2018 7:55 am

Re: External web file not updating.

Post by Rusty » Fri Aug 31, 2018 3:36 pm

A gif file is updated from our weather station every 10 minutes to a sub directory of public_html on our host.
I want that gif image to be on a responsive page I have on my WWB site.
WWB preview show the preview image but I have to do a full site upload & reboot pc to see if it works in different browsers any text or other changes are ok I can see them when I refresh the browsers.
I assume InLine Frame is the correct way to insert the gif on a page or is there another way.

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Fri Aug 31, 2018 3:52 pm

I want that gif image to be on a responsive page I have on my WWB site.
You can display the image, just like any other image.
WWB preview show the preview image but I have to do a full site upload & reboot pc to see if it works in different browsers any text or other changes are ok I can see them when I refresh the browsers.
This has nothing to do with WWB. If the image is not updated then it's most likely an issue with the browser's cache.
I assume InLine Frame is the correct way to insert the gif on a page or is there another way.
If it's only a gif image, then you can insert it via the Image object.

Rusty
 
 
Posts: 39
Joined: Sun Aug 12, 2018 7:55 am

Re: External web file not updating.

Post by Rusty » Sat Sep 01, 2018 7:34 am

I have tried to do it via Image object but it seams to take a snap shot of the gif at that time and uses that if I then link the snap shot you have to click on the image to get the updated image. I just want to have a updated image shown on the page.

The responsive problem I have is on the default page the gif is 383,295 and shows fine, but if I try and squeeze or manually change the size on the 320 and or the 768px it cuts down the image and doesn't show the hole image.

I am new to WWB just cross from S**if WP8 after 20 odd year I have converted all that site to be responsive on WWB but this is the only problem I have I think.

User avatar
Billywiz
 
 
Posts: 130
Joined: Thu Jul 17, 2008 3:32 pm
Location: UK
Contact:

Re: External web file not updating.

Post by Billywiz » Sat Sep 01, 2018 8:32 am

What is the name of the widget you use or is it an actual weather station at your property that updates the image.
If it is a widget that can be downloaded let me have the address and I will check the settings to see if I can solve the problem.

Cheers

"On edit" If I refresh the page after 15 minutes then the new image and the time it was uploaded shows so it looks as though a page refresh is needed each time you visit (image uploads every 10 mins). If it is a new visitor they will see the new image
Last edited by Billywiz on Sat Sep 01, 2018 9:35 am, edited 1 time in total.
At last, website finished - - - - but wait !!!!

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Sat Sep 01, 2018 9:22 am

Maybe you have applied a filter or effect to the image? In that case it will be published as a new image.
Normally the image will be published "AS IS", so if it does not work then the issue is not related to WWB.

Rusty
 
 
Posts: 39
Joined: Sun Aug 12, 2018 7:55 am

Re: External web file not updating.

Post by Rusty » Sat Sep 01, 2018 9:30 am

This is the gif https://garliestonlodge.co.uk/weather/summary.gif it up dates ever 10 min in the /weather/ directory.

User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Sat Sep 01, 2018 9:37 am

And where on your website are you using the GIF?


User avatar
Pablo
 
Posts: 14128
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: External web file not updating.

Post by Pablo » Sat Sep 01, 2018 10:12 am

It does not look like the image is updated.
I think you will have to check the weather station configuration.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest