email link???

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
Post Reply
Trugmaker
 
 
Posts: 132
Joined: Mon Mar 23, 2015 3:11 pm
Location: East Sussex UK
Contact:

email link???

Post by Trugmaker » Sat Jan 06, 2018 11:12 am

I have just gone HTTPS and changing a few things, when I add a mailto:contact@trugmakers.co.uk text link, but when I upload it just opens my email programme instead of sending an email??? Any Clues?
Never complain about getting old, the alternative is far worse!

User avatar
Pablo
 
Posts: 18406
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: email link???

Post by Pablo » Sat Jan 06, 2018 11:19 am

when I upload it just opens my email programme instead of sending an email??? Any Clues?
Correct. This is how it is suppose to work.

Related FAQ:
viewtopic.php?f=10&t=135

Trugmaker
 
 
Posts: 132
Joined: Mon Mar 23, 2015 3:11 pm
Location: East Sussex UK
Contact:

Re: email link???

Post by Trugmaker » Sat Jan 06, 2018 11:36 am

I don't understand. If I want to include a feedback form (not using the WWB form option) and I want to add an email link to send me an email with that info. I repeat it does not send the info, just opens the senders email programme.
Never complain about getting old, the alternative is far worse!

User avatar
Pablo
 
Posts: 18406
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: email link???

Post by Pablo » Sat Jan 06, 2018 11:44 am

A 'mailto' link is a standard HTML feature. The functionality is implemented in the browser. You have no control over this from the HTML.
The normal behavior of a 'mailto' link is to open the default email application.
https://developer.mozilla.org/en-US/doc ... hyperlinks

Note that this has nothing to do with WWB. This is just how it works.

User avatar
BaconFries
 
 
Posts: 4403
Joined: Thu Aug 16, 2007 7:32 pm

Re: email link???

Post by BaconFries » Sat Jan 06, 2018 11:51 am

How did you expect it to work? Where is the form located then if you are not the WWB form option? As mentioned by yourself "when I add a mailto:contact@trugmakers.co.uk text link" then all this is, is a text link telling it to open your email or users client they have installed on there PC as there is no form.

Trugmaker
 
 
Posts: 132
Joined: Mon Mar 23, 2015 3:11 pm
Location: East Sussex UK
Contact:

Re: email link???

Post by Trugmaker » Sat Jan 06, 2018 11:56 am

Get it now -Thanks again
Never complain about getting old, the alternative is far worse!

Trugmaker
 
 
Posts: 132
Joined: Mon Mar 23, 2015 3:11 pm
Location: East Sussex UK
Contact:

Re: email link???

Post by Trugmaker » Sat Jan 06, 2018 12:31 pm

OK, This is why I 'attempted' to make my own form. When I used the form wizard, nomatter how I tried, the submit button sits at the top of the screen although when I preview it is where it should be? Please see example https://www.trugmakers.co.uk/contact-trugs.html
Never complain about getting old, the alternative is far worse!

User avatar
Pablo
 
Posts: 18406
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: email link???

Post by Pablo » Sat Jan 06, 2018 1:40 pm


Trugmaker
 
 
Posts: 132
Joined: Mon Mar 23, 2015 3:11 pm
Location: East Sussex UK
Contact:

Re: email link???

Post by Trugmaker » Sun Jan 07, 2018 10:43 am

Sorted - my fault entirely, several problems I have had has been caused by forgetting to alter the responsive pages within the same page - I believe this may be a recurring problem with other 'less techno' users. I resorted to using a stand-alone form maker only to discover what the problem was afterwards - now I will be removing that software and revert to using WWB form maker!
Never complain about getting old, the alternative is far worse!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests