mailto:

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
Post Reply
RonJ
 
 
Posts: 25
Joined: Fri Feb 08, 2008 2:51 am

mailto:

Post by RonJ » Mon Dec 25, 2017 3:41 pm

I use the "mailto:" link. It works well on my WIN10 desktop and my Android smartphone opening my Gmail program as it should. I just noticed that it does not work on my wifes WIN10 laptop.

I now wonder if the links work on other peoples computers, if not, they would have to copy/paste which would be difficult for many of my older users.

Is there an issue with this link or is it a problem with the users browser? My desktop uses Chrome as does my wife's laptop, it works for me but not my wife.

The site with links is: http://www.whitewaterevents.ca/events.html

Thanks, RonJ

User avatar
BaconFries
 
 
Posts: 4582
Joined: Thu Aug 16, 2007 7:32 pm

Re: mailto:

Post by BaconFries » Mon Dec 25, 2017 5:18 pm

Most likely this is due to the used email client has not been set up on your wife's Laptop. Note this is unrelated to the programme but a configuration of the Laptop and the email client used to send and receive emails.

RonJ
 
 
Posts: 25
Joined: Fri Feb 08, 2008 2:51 am

Re: mailto:

Post by RonJ » Mon Dec 25, 2017 5:22 pm

Thanks, that could well be true of many other computers too.

Would the same be true if I set up a contact box with php?

User avatar
Pablo
 
Posts: 20167
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: mailto:

Post by Pablo » Mon Dec 25, 2017 6:35 pm

See also this related FAQ:
viewtopic.php?f=10&t=135
Would the same be true if I set up a contact box with php?
No, in that case the form will be processed on the server.

RonJ
 
 
Posts: 25
Joined: Fri Feb 08, 2008 2:51 am

Re: mailto:

Post by RonJ » Tue Dec 26, 2017 7:59 pm

Setting up a php contact box using Form Wizard. When I upload it, the box appears, I can fill it out and it shows up in my mail as it should. If I close the website and then comeback to it, the box is missing. Upload again, the box returns. Use it, leave the site and then comeback, the box doesn't reload with the page. I have to upload the page again. Any suggestions?

User avatar
Pablo
 
Posts: 20167
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: mailto:

Post by Pablo » Tue Dec 26, 2017 9:15 pm

What 'box' are you referring to?
Where do I need to look to see it?

RonJ
 
 
Posts: 25
Joined: Fri Feb 08, 2008 2:51 am

Re: mailto:

Post by RonJ » Tue Dec 26, 2017 11:44 pm

Go to: http://www.whitewaterevents.ca

Click on the menu item EVENTS, you will see it goes to: http://www.whitewaterevents.ca/events.html

In the address bar, change the http://www.whitewaterevents.ca/events.html to events.php, click enter.

The page will come up: http://www.whitewaterevents.ca/events.php with the contact box(form). You must scroll far, far down the page, I wanted it out of sight while trying to get this to work.

The contact box will work as it should, but if I leave the page, back to the HOME page for instance, and come back to the EVENTS page, the html page comes back without the contact box. The php page does not come back

I hope all that isn't too confusing ... :?

User avatar
BaconFries
 
 
Posts: 4582
Joined: Thu Aug 16, 2007 7:32 pm

Re: mailto:

Post by BaconFries » Wed Dec 27, 2017 2:10 am

Without sounding rude it is only confusing because you are making it so. If you do not wish it to go to events.html but rather events.php each time, then it should be named events.php!!. Note you cannot preview forms using php pages locally on your PC due to it requiring it to be uploaded to your host/web server. If you wish to simply view the page you can enable 'Remove PHP during preview' in Tools->Options->Preview however this will not modify your sites structure, and all links/navigation will still be pointing to the PHP pages. So to solve name the page events.php and remove the events.html page and configure your menu to match.

User avatar
Pablo
 
Posts: 20167
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: mailto:

Post by Pablo » Wed Dec 27, 2017 8:09 am

- remove events.html page from the server.
- change all links from events.html to event.php
- republish all pages that link to this page.

RonJ
 
 
Posts: 25
Joined: Fri Feb 08, 2008 2:51 am

Re: mailto:

Post by RonJ » Wed Dec 27, 2017 5:35 pm

Thanks, now working as it should, ... :)

http://www.whitewaterevents.ca/events.php

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests