Multiple Link Responsive Text Blocks Inheriting First link URL

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Multiple Link Responsive Text Blocks Inheriting First link URL

Post by ColinM » Mon Jun 12, 2017 6:47 am

Hi Pablo,

I'll send you the link to the project file via email soon.

A) I've read all the associated threads
http://www.wysiwygwebbuilder.com/forum/ ... 19&t=74808
http://www.wysiwygwebbuilder.com/forum/ ... =1&t=73558
viewtopic.php?f=1&t=73734
http://www.wysiwygwebbuilder.com/forum/ ... =1&t=73500
http://www.wysiwygwebbuilder.com/forum/ ... xt#p379957

B) I have the latest version of WB 12.0.5 (June 6,2017)

C) I have windows 10 Version 1703 (OS Build 15063.332) which should be well past the anniversary version.

D) I did not have a WB alternative to the msftedit.dll in the Web Builder 12 root directory.

E) The multiple links worked fine if I left the text block at default.

F) If I changed the text block to Enable Responsive Fonts - Include Line Height... the text links in the text block after the first text link took the URL value of the first link.

G) I downloaded the msftedit.dll file, installed it in the Program Files(x86)/WYSIWYG Web Builder 12 root directory and the problem went away.
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by Pablo » Mon Jun 12, 2017 7:01 am

If you have WB12 then you do not need the msftedit.dll file. Please remove it, because it may have side effects with Wb12.

I was not able to reproduce the behavior you have described, can you please share your project file?
But maybe you have not used a hard return (enter) between the links?

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by ColinM » Mon Jun 12, 2017 7:17 am

Thanks for the quick reply Pablo.

I'm a bit confused - is not a hard return a carriage return that would force a line break? I want the sentence to continue with the links in it and wrap when the text block boundary is encountered.

I renamed that DLL file to BAK - went back into the project and the links seem ok - very confusing.

Zipped project file on it's way Pablo.
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by Pablo » Mon Jun 12, 2017 7:27 am

There needs to be a space, line break or other type of separator between the links otherwise it will be one continuously link.

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by ColinM » Mon Jun 12, 2017 7:35 am

Pablo wrote:
Mon Jun 12, 2017 7:27 am
There needs to be a space, line break or other type of separator between the links otherwise it will be one continuously link.
Yes, I understand that Pablo - but if you look at the home page and the paragraph with the links in it they are well separated with words and spaces and the second and third link still inherits the value of the first link.
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by Pablo » Mon Jun 12, 2017 7:46 am

In the project (wiglive2_001.wbs) you have sent me, all 3 links are unique. Even when I preview the page.
However there are two files
wiglive2_001.wbs (last saved today -> good)
wiglive2_001_1.wbs (last saved 6/9/2017 -> not good)

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by ColinM » Mon Jun 12, 2017 8:41 am

Yes - ignore the wiglive2_001_1.wbs one Pablo that's a previous.

OK, I've removed the DLL file from the WB root directory I'll see how I go.
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by ColinM » Mon Jun 12, 2017 8:56 am

OK - Pablo - having removed the DLL file from the WB 12 root directory with that 2_001 project - Our Wines page

a) I can set the links for ow_text object - save them and they are all fine.
b) I then set the links for the ow_text1_m object and they are fine. (480/320 BPs)
c) But when I go back to the 1920 BP and check the links in the ow_text object they have reverted back to the value of the first URL :?
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by Pablo » Mon Jun 12, 2017 9:12 am

But these are different text objects, right?
Also where do I find the 'ow_text' object?

Can you please describe the exact steps (including the exact ID of the objects) , so I can see where it goes wrong for you?
Maybe you are mixing up text objects, somehow? Because I do not think this is related to any of the previous Windows 10 related issues.
For example, on the 480 breakpoint the object 'index_text_2' is visible. Is this intended?

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by ColinM » Mon Jun 12, 2017 9:23 am

OK, lets see if I can make it clearer: :D

a) I'm only talking now about the our_wines page.
b) Object (text) ow_text (this is used for all BPs except 480/320) I set the links.
c) I the save the project - links are fine.
d) I then go to the 320 BP and edit ow_text1_m object (mobile version of ow_text), set the links and save the project.
e) I go back to the 1920 BP and the links in the ow_text object are all set to the value of the first link in that object.

I can solve this by setting ow_text to default - same issue as reported here
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by Pablo » Mon Jun 12, 2017 9:51 am

Thanks. I was now able to reproduce this behavior. It looks like Microsoft has introduced a new bug in the editor. It will try to find a workaround a.s.a.p.

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: MULTIPLE LINK TEXT BLOCKS - Still Need To Install msftedit.dll

Post by ColinM » Mon Jun 12, 2017 8:32 pm

Pablo wrote:
Mon Jun 12, 2017 9:51 am
Thanks. I was now able to reproduce this behavior. It looks like Microsoft has introduced a new bug in the editor. It will try to find a workaround a.s.a.p.
Awesome Pablo - glad all our hard work bore fruit - thanks heaps for your help on this one as always.

I'll stay away from responsive multiple link text blocks in the meantime and have changed the name of this thread so as not to encourage reuse of a WB local DLL file.
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Multiple Link Responsive Text Blocks Inheriting First link URL

Post by Pablo » Tue Jun 13, 2017 5:42 am

In the meantime I have found a workaround but it needs more testing so it will probably be available later this week.
I have also tested with the local DLL and that seems to work correct for a temporary fix.

User avatar
ColinM
 
 
Posts: 503
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: Multiple Link Responsive Text Blocks Inheriting First link URL

Post by ColinM » Tue Jun 13, 2017 8:06 pm

Pablo wrote:
Tue Jun 13, 2017 5:42 am
In the meantime I have found a workaround but it needs more testing so it will probably be available later this week.
I have also tested with the local DLL and that seems to work correct for a temporary fix.
OK - so that means I can reinstate that DLL file locally Pablo until a permanent fix is confirmed?
Yours truly
Colin M
Western Australia
FORUM MODERATOR
Please think before you post, be polite, don't hijack threads and above all please respect Pablo's huge effort!
My Website

User avatar
Pablo
 
Posts: 12582
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Multiple Link Responsive Text Blocks Inheriting First link URL

Post by Pablo » Tue Jun 13, 2017 8:12 pm

OK - so that means I can reinstate that DLL file locally Pablo until a permanent fix is confirmed?
Yes, that works for me.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests