How to trouble shoot Web Builder Extension issues?

Frequently Asked Questions about WYSIWYG Web Builder
Locked
User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

How to trouble shoot Web Builder Extension issues?

Post by Pablo » Fri Jan 18, 2008 7:40 pm

Important notes (please read carefully):
Extensions can only be used in the full version/paid of the software. You will need an official license! Extensions are only available for registered users!
Extensions are not officially supported, they are made available as an extra service for the users of WYSIWYG Web Builder that find them useful and the software is provided "AS IS". They are not an official part of the software! Pablo Software Solutions will not offer support for third party extensions and is in no way responsible for proper functioning of these extensions.

Some third party extension developers do offer support! See the dedicated extension section of this forum.
http://wysiwygwebbuilder.com/forum/viewforum.php?f=42

The current version of WYSIWYG Web Builder supports a maximum of 200 extensions, this is a limitation in the way Windows loads external processes) Basically each extension is an external process, so loading 200 extensions is like launching 200 applications of your computer. To prevent the application from becoming unstable we had to built-in a maximum for the number of extensions to reserve memory/system resources for other application functionality.
But anyway, it is not recommended to install unused extensions because this will take up unnecessary memory and may slow down the application.

Trouble shooting:
1) Make sure you have the minimum required version of WYSIWYG Web Builder.
2) Make sure you have the latest version of the extension(s). And only download the files from our website!
3) Extensions should be installed (= unzipped) in the My Documents\WYSIWYG Web Builder\system\extensions
However if you change the default document folder in Menu->Options->Tools->Files & Folder->System Folder then the folder for extensions will also change!

So for instance if you've changed it to C:\My Web Sites\ then the system folder (and all sub folders) will be in
C:\My Web Sites\system\
and extensions will be in
C:\My Web Sites\system\extensions

After you have restarted the software the extensions will be available in the toolbox:
Image

Note that you do not have to load the extensions manually, they will automatically be detected by the software! If not, then please carefully read the instructions again.
Last edited by Pablo on Sun Jun 27, 2010 9:23 am, edited 1 time in total.

User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Post by Pablo » Tue Jun 23, 2009 6:24 pm

Official extensions are available here for manual download:
http://extensions.wysiwygwebbuilder.com/

But you can also use the Extension Manager.
Menu->Tools->Extension Manager

Image

User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: How to trouble shoot Web Builder Extension issues?

Post by Pablo » Mon Feb 11, 2013 9:03 pm

If you manually install extensions (by copying them to the extension folder) then you may need to reset the toolbox.
Right click the toolbox and select "Reset toolbox' or use 'Customize' to drag & drop the newly installed extensions to the toolbox.

If you experience problems with loading extension then make sure you did not install more than 200.
Also make sure the extension was designed for the version of Web Builder you are using (see the documentation of the extension).

User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: How to trouble shoot Web Builder Extension issues?

Post by Pablo » Fri Mar 11, 2016 7:14 pm

When you have startup problems (slow loading) or pages are unstable it may be caused by an outdated or corrupt extension.
The quickest way to find out if an the problem is related to one (or more) extensions(s) is by temporarily disable them.

1. Go to the extension folder : Documents\WYSIWYG Web Builder\system\extensions\
2. Rename 'extensions to 'extensions_off'
3. Restart the application.
If that solves the problem then the next step if to find out which one of the extensions is causing trouble.
You can do this by moving extensions (.wbx and .uwbx files) to another folder one by one until it works.

User avatar
Pablo
 
Posts: 19658
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: How to trouble shoot Web Builder Extension issues?

Post by Pablo » Mon Aug 21, 2017 8:19 pm

If you have copied the documents folder (including extensions) from a backup then the folder may have the wrong permissions/credentials, so WWB cannot access the files.

In that case try this:
1. Close the application
2. Go to the extensions folder
3. Rename the folder, for example to 'extensions_old'.
4. Restart the application, the extensions folder will be recreated with the correct permissions
5. Close the applications again.
6. Copy the extensions from 'extensions_old' to 'extensions'.

Locked

Who is online

Users browsing this forum: No registered users and 2 guests